Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6170 closed defect (fixed)

GUI: Dreamweb error abort on Savegame dialog

Reported by: SF/einstein95 Owned by: lordhoto
Priority: normal Component: Engine: Dreamweb
Version: Keywords:
Cc: Game: Dreamweb

Description

When you start, go to options, disk options, and save. The console displays the error "Could not load widget position for 'SaveLoadChooser.PageDisplay'!". However, if you open the ScummVM menu (ctrl+F5), the game saves properly. I am running ScummVM 1.6.0git2025-g880ac5d (Oct 24 2012 04:45:48).

Ticket imported from: #3580300. Ticket imported from: bugs/6170.

Change History (9)

comment:1 by lordhoto, 11 years ago

What system are you running this on? And what is your graphics mode setting?

comment:2 by SF/einstein95, 11 years ago

I am running Windows 7 Ultimate x86 and my graphics mode is set to default.

comment:3 by digitall, 11 years ago

This error comes from the function void GuiObject::reflowLayout() found in scummvm/gui/object.cpp.

The SaveLoadChooser.PageDisplay is called from the SaveLoadChooserGrid constructor in scummvm/gui/saveload-dialog.cpp, specifically line 545, where this is the name of the staticTextWidget.

As far as I can understand this, the base position is loaded in from the Theme XML.

Since the SaveLoadChooserGrid display was added recently to the Theme XML i.e. 90eb773c5d862d38f3dc834d51c5a57319c61c3f, I would suspect that the problem is that the user is loading an older external theme file, which lacks these fields.

comment:4 by digitall, 11 years ago

einstein95: Could you do the following: 1. Please report if you are using the Modern or Classic theme and whether you have configured to an external theme path? This can be found under "Options"->"Paths" tab->Theme Path.

2. Please can you search your configuration file i.e. http://wiki.scummvm.org/index.php/User_Manual/Configuring_ScummVM#Using_the_configuration_file_to_configure_ScummVM for the "themepath" entries, and report the result here.

3. Please try this from a new clean configuration file state i.e. backing up your configuration file to another directory and removing your current configuration file from the path given above.

comment:5 by digitall, 11 years ago

Summary: DREAMWEB: Crash on in-game saveGUI: Dreamweb error abort on Savegame dialog

comment:6 by lordhoto, 11 years ago

The theme file version was bumped when the chooser was introduced, so it should not be possible to use outdated theme files. This was done in the commit you referenced.

The PageDisplay widget is not present in the low resolution theme files, because the chooser is only ever used for high-resolution (i.e. 640x400 or higher). There is code which assures that the grid based chooser is not used, when a lower resolution is used. But this might fail due to some reason...

I was successfully able to reproduce the issue described in this bug by starting Dreamweb, then lowering the scale factor to 1x via hotkeys and afterwards trying to open the in-game save dialog. This was caused by the GUI not getting a chance to refresh its settings and thus still think it's high-res even though actually the next time some layouting was done it was in low resolution mode already. I committed a fix for that issue in 0052ef2802ce2f6306338a180a4833708f7e7af1.

Might be that this fixes the issue described here. But I don't know whether you (the bug reporter) changed the resolution like this when you encountered this problem.

comment:7 by SF/einstein95, 11 years ago

Resolution: fixed
Status: newclosed

comment:8 by SF/einstein95, 11 years ago

Marking this as fixed with latest build. I didn't change the resolution using hotkeys, however.

comment:9 by lordhoto, 11 years ago

Owner: set to lordhoto
Note: See TracTickets for help on using tickets.