Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#6114 closed defect (worksforme)

AGOS: Feeble Files - Can't go left in Interrogation

Reported by: SF/pawelch Owned by: eriktorbjorn
Priority: high Component: Engine: AGOS
Keywords: Cc:
Game: The Feeble Files

Description

Hi, I've been playing The Feeble Files for some time (the 2CD/Windows/Polish version) and at some point I've found the dead end (near the end of the game). No matter what I couldn't go left in the Interrogation room after poisoning the interrogators.
The savegame is attached.

The same occurs when I use attached savegame in the original game (after decompressing and renaming).

I guess it's some kind of bug originating from original game and I hope you can fix it easily.

Tested on:
* ScummVM 1.5.0 on Windows
* ScummVM 1.6.0git240-g52a1a6e (Aug 3 2012 22:41:20) on Windows
* original game on Ubuntu 12.04/Wine 1.4

Ticket imported from: #3554249. Ticket imported from: bugs/6114.

Attachments (1)

feeble.016 (1.2 KB) - added by SF/pawelch 7 years ago.

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by SF/pawelch

Attachment: feeble.016 added

comment:1 Changed 7 years ago by digitall

Summary: FEEBLE: can't go left in Interrogation roomAGOS: Feeble Files - Can't go left in Interrogation

comment:2 Changed 7 years ago by digitall

Replicated by loading from attached savegame with Linux x86_32 and Feeble Files 2CD/Windows/English.

Have confirmed that this is due to the screen failing to scroll left when you walk to the left side. Looks like a problem in the game state variables.

comment:3 Changed 6 years ago by sev-

Priority: normalhigh

comment:4 Changed 6 years ago by sev-

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:5 Changed 6 years ago by sev-

Owner: set to Kirben

comment:6 Changed 6 years ago by eriktorbjorn

Are you sure you solved the puzzle correctly? The game acts as if the interrogators aren't knocked out, and to do that you need to close all the air vents. I could be mistaken, but when I load that savegame into the English version of the game, the vent in Research and Testing is open. (Not the vent above the firing range, the one on the far right side of the room.)

If I do this:

1) Close the vent in Research and Testing (pushing the button on the wall)
2) Re-open the vent above the firing range (removing the metal plate covering it)
3) Release knockout gas in the firing range
4) Put back the cover over the firing range vent
5) Reverse the direction of the ventilation fans (from suck to blow)

Then the interrogators are unconscious, and I can go left in the interrogation area.

comment:7 Changed 6 years ago by SF/pawelch

When I load the savegame the vent on the top right edge of Research and Testing is closed. Also Feeble says it is closed when I click it with magnification glass. Clicking yellow VENT button changes nothing.

From what I remember when I played this game last time, the poison reached the interrogators and I've seen the animation for that, so I guess the puzzle was solved correctly. Unluckily I don't have any savegame from the moment before that, otherwise I'd try to solve it again.

comment:8 Changed 6 years ago by SF/pawelch

Regardless my previous comment I've repeated the steps 2-5 and this helped. I can go left in Interrogation. Thank you for your support.

comment:9 Changed 6 years ago by eriktorbjorn

Since it's not certain that there was a bug, and if there was one we don't really have any way of reproducing it, and either way you did get past the puzzle in the end, I'm going to close this bug report. Of course, if you do manage to find the steps to reproduce it, feel free to file a new bug report.

comment:10 Changed 6 years ago by eriktorbjorn

Keywords: original removed
Owner: changed from Kirben to eriktorbjorn
Resolution: worksforme
Status: newclosed

comment:11 Changed 6 years ago by SF/pawelch

Hi, closing it is fine with me. I have no idea what would be the reproduction steps. Thanks again for help.

Note: See TracTickets for help on using tickets.