Opened 7 years ago

Closed 7 years ago

#6090 closed defect (fixed)

TSAGE: Blue Force CD - Finale Script Bug

Reported by: SF/truus999 Owned by: dreammaster
Priority: normal Component: Engine: TsAGE
Keywords: script Cc:
Game: Blue Force

Description

In the final part of the game you're supposed to tie both criminals. seatch them and hand them to the authroriteis.
You do this by clicking the yellow cable from your inventory on both criminals and afterwards clicking with the hand cursor on them.
This works for the DA but although he is tied Snake Dillon still pulls his gun out and shoots you.

One extra observation: After being tied clickong the eye cursor on both men you get the answer for snake Dillon als if you look at the DA.

How to reproduce:
Load the saved game

Ticket imported from: #3541354. Ticket imported from: bugs/6090.

Attachments (2)

blueforce-cd.048 (20.6 KB) - added by SF/truus999 7 years ago.
blueforce-cd.046 (23.2 KB) - added by SF/truus999 7 years ago.
save as requested

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by SF/truus999

Attachment: blueforce-cd.048 added

comment:1 Changed 7 years ago by SF/truus999

How to reproduce:
Load the saved game
Click the yellow cord from your inventory on snake Dillon
Click the yellow cord from your inventory on the DA
click the handcursor on snake Dillon and you'll die
(you can click the hand cursor first on the DA and that one works fine, clicking on snake Dillon next gives the same death).

BTW you can fisnish the game by skipping the search and talking to the ATF agent who enters after tieng the criminals down.

comment:2 Changed 7 years ago by digitall

Owner: set to dreammaster
Summary: Blue Force: Bug at the finaleTSAGE: Blue Force CD - Finale Script Bug

comment:3 Changed 7 years ago by digitall

Replicated with Blue Force CD/DOS/English on Linux x86_32 with latest Git master.

Tie up Snake, then click on him to search him and his state incorrectly jumps to un-tied and he shoot you.
Running with valgrind shows no memory issues.

dreammaster: Any ideas?

comment:4 Changed 7 years ago by dreammaster

Okay, I've checked in the original (luckily I have some savegames), and the problem is a state change that's meant to happen when you call Cox into the room. Unfortunately, to trace the problem, I need a savegame from before Nico enters the room. Do you have any savegame from just before it in ScummVM? It would save me from having to play through the game until that point do I can test the problem.

comment:5 Changed 7 years ago by digitall

dreammaster: Sorry, I don't have any and would also have to play through to get some.

truus999: Do you have savegames at this point?

Changed 7 years ago by SF/truus999

Attachment: blueforce-cd.046 added

save as requested

comment:6 Changed 7 years ago by SF/truus999

addes save as requested

comment:7 Changed 7 years ago by dreammaster

Thanks, that did the trick. I've identified the missing state change, and now you can search Nico without being shot.

comment:8 Changed 7 years ago by dreammaster

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.