Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6089 closed defect (fixed)

MOHAWK: LB - Text animations not working

Reported by: SF/legoking831 Owned by: fuzzie
Priority: normal Component: Engine: Mohawk
Keywords: Cc:
Game:

Description

Before you go off and tell me this is a duplicate of bug 3419094, that report was misunderstood as I don't think the user was specific enough when he described those. So, allow me to explain. I have a video this time to help you figure out what I mean.
The New Kid on the Block and Dr. Seuss's ABC both have animations assigned to their text, beyond just having it read aloud. As in, not only does it read the text, but it triggers an animation along with it. ScummVM fails to play these animations though, and only reads the text. For ABC, it doesn't apply to all the text ("What begins with [letter]?" and the C...c...C type things work), but it does apply to all the text in New Kid, which completely ruins the whole point of the game. You don't need an actual copy of New Kid, this bug is also in the demo (which I actually used in the video, but I can confirm it's this way in the real game too). Check out the video cited below. I first show how it should run using the original EXE/interpreter, then show how it currently runs in ScummVM:
http://www.youtube.com/watch?v=2C9QhsU2EE4
Also, while we're here, I should also mention the "BIG" and "little" text in ABC simply doesn't work at all. I tried clicking it at the end of the video, and nothing happened.

Ticket imported from: #3541294. Ticket imported from: bugs/6089.

Attachments (1)

SEUSSABCMD5.txt (6.4 KB ) - added by SF/legoking831 7 years ago.
MD5s for my version of ABC

Download all attachments as: .zip

Change History (16)

comment:1 by digitall, 7 years ago

Summary: LB: Textual animations not workingMOHAWK: LB - Text animations not working

comment:2 by digitall, 7 years ago

The bug that the bug submitter is referring to is "LB: Missing Animations" - ID: 3419094:
https://sourceforge.net/tracker/?func=detail&aid=3419094&group_id=37116&atid=418820

This was closed as the bug submitter did not respond clearly with sufficient detail to identify the exact version and it was not possible to replicate the bug from their report.

legoking831: I will try to replicate here again, but if you could supply the information the original submitter failed to:
"Can you be clear about the following:
1. What operating system are you using?
2. What release of ScummVM are you using?
3. Have you tried replicating this issue with the latest nightly
development builds from:
http://www.scummvm.org/downloads/#daily

Also, you may have an unsupported version or variant of these LB games
(Unfortunately several LB titles were released with varying engine
versions, and we only support the earlier engine versions currently. This
is not helped by the fact they are very hard to tell apart by inspection of
the packaging)

In order to progress this bug, apart from the answers to the previous
questions, can you please attach a text file to this bug containing a file
listing of your Dr. Seuss ABC CD contents with MD5sum file checksums. The
output of a tool such as http://md5summer.org/ would be optimal."

comment:3 by digitall, 7 years ago

Owner: set to fuzzie

comment:4 by digitall, 7 years ago

Assigning to Mohawk LB developer for visibility.

comment:5 by digitall, 7 years ago

legoking831: OK. Have managed to replicate with latest Git master on Linux x86_32 using the New Kid Demo here:
https://sourceforge.net/projects/scummvm/files/demos/mohawk/newkid-win-demo-en.zip/download

I concur that there is a bug here compared to your video of the original. To replicate:
1. Start "New Kid Demo".
2. After intro, Click "Let Me Play".
3. Wait for "I Spied My Shadow Slinking" Poem First Read to complete. Boy animates.
4. Click on the words to play the poem. The words animate correctly.
However, the boy stays totally still. In the original, as the video linked shows, he animates through various actions connected to the words.

fuzzie: Any immediate ideas?

comment:6 by digitall, 7 years ago

legoking831: Please disregard request for more information as we can now replicate with a freely available demo, so the Mohawk LB engine developers can investigate. Please note that this may take a little time, so please be patient and stand by... Thanks.

comment:7 by SF/legoking831, 7 years ago

Alright, no problem. I'm fine with waiting :)

comment:8 by fuzzie, 7 years ago

Drat. The animations *do* work in some versions of those two games, which is confusing.

While this is much easier to replicate with a demo that we have (hooray), could you still either provide the interpreter version (it might be under Properties on Windows), or else attach the outline files for the failing games?

comment:9 by fuzzie, 7 years ago

The demo issues reproduced by digitall (thanks!) should be fixed by revision e265be07, which will be in the next daily build. Hopefully it will fix your reported problems - please report if they're fixed or not!

comment:10 by digitall, 7 years ago

Resolution: fixed
Status: newpending

by SF/legoking831, 7 years ago

Attachment: SEUSSABCMD5.txt added

MD5s for my version of ABC

comment:11 by SF/legoking831, 7 years ago

Well, now we've managed to turn the bug around the other way. The animations are working, yes, but now the text isn't being read. It just skips directly to the animation, both on New Kid and ABC. I have this problem on my V1.1 disc of New Kid on the Block. To tell the difference between V1.0 and V1.1 of the first four games, for future reference...
V1.0 will have the label "Broderbund's Living Books". V1.1 says "Living Books: A Random House/Broderbund Company".
V1.0 came on separate Windows and Macintosh CDs. V1.1 uses hybrid Windows/Mac CDs.
I'm quite certain there was only ever one version of Dr. Seuss's ABC, but here's the info I've got anyway for the version that isn't working.
Outline:
[BookInfo]
title="Dr. Seuss's ABC version 1.0"
copyright="Copyright 1995, Living Books"
fPoetry=false
nPages="50"
nLanguages="1"
xRes="512"
yRes="384"
;optional configuration info
fNeedPalette=true
fUse254ColorPalette=false
nColors=256
nKBRequired=2560

[Languages]
Language1="English"

[Intro]
Page1.r=MHKDATA\CP\ABCINTRO.MHK
Page2.r=MHKDATA\CP\ABCCOVER.MHK

[Control]
Page1=MHKDATA\CP\ABCPANEL.MHK
Page2=MHKDATA\CP\ABCQUIT.MHK
Page3=MHKDATA\CP\ABCOPT.MHK

[Credits]
Page1.r=MHKDATA\CP\ABCCRED1.MHK
Page2.r=MHKDATA\CP\ABCCRED2.MHK
Page3.r=MHKDATA\CP\ABCCRED3.MHK

[English.Play]
Page1=MHKDATA\EP\ABC_A_EP.MHK
Page2=MHKDATA\EP\ABC_B_EP.MHK
Page3=MHKDATA\EP\ABC_C_EP.MHK
Page4=MHKDATA\EP\ABC_D_EP.MHK
Page5=MHKDATA\EP\ABC_E_EP.MHK
Page6=MHKDATA\EP\ABC_F_EP.MHK
Page7=MHKDATA\EP\ABC_G_EP.MHK
Page8=MHKDATA\EP\ABC_H_EP.MHK
Page9=MHKDATA\EP\ABC_I_EP.MHK
Page10=MHKDATA\EP\ABC_J_EP.MHK
Page11=MHKDATA\EP\ABC_K_EP.MHK
Page12=MHKDATA\EP\ABC_L_EP.MHK
Page13=MHKDATA\EP\ABC_M_EP.MHK
Page14=MHKDATA\EP\ABC_N_EP.MHK
Page15=MHKDATA\EP\ABC_O_EP.MHK
Page16.1.r=MHKDATA\EP\ABC_P1EP.MHK
Page16.2=MHKDATA\EP\ABC_P2EP.MHK
Page17=MHKDATA\EP\ABC_Q_EP.MHK
Page18=MHKDATA\EP\ABC_R_EP.MHK
Page19=MHKDATA\EP\ABC_S_EP.MHK
Page20=MHKDATA\EP\ABC_T_EP.MHK
Page21=MHKDATA\EP\ABC_U_EP.MHK
Page22=MHKDATA\EP\ABC_V_EP.MHK
Page23=MHKDATA\EP\ABC_W_EP.MHK
Page24=MHKDATA\EP\ABC_X_EP.MHK
Page25=MHKDATA\EP\ABC_Y_EP.MHK
Page26.1.r=MHKDATA\EP\ABC_Z1EP.MHK
Page26.2=MHKDATA\EP\ABC_Z2EP.MHK
Page27.r=MHKDATA\EP\ABCEND.MHK
Page28=MHKDATA\EP\FOO.MHK
Page29=MHKDATA\DEMO\DEMOPAGE.MHK
Page30.r=MHKDATA\DEMO\JMCOVER.MHK
Page31=MHKDATA\DEMO\JMDEMO.MHK
Page32.r=MHKDATA\DEMO\ATCOVER.MHK
Page33=MHKDATA\DEMO\ATDEMO.MHK
Page34.r=MHKDATA\DEMO\THCOVER.MHK
Page35=MHKDATA\DEMO\THDEMO.MHK
Page36.r=MHKDATA\DEMO\NKCOVER.MHK
Page37.1=MHKDATA\DEMO\NKDEMO1.MHK
Page37.2=MHKDATA\DEMO\NKDEMO2.MHK
Page38.r=MHKDATA\DEMO\RBCOVER.MHK
Page39=MHKDATA\DEMO\RBDEMO.MHK
Page40.r=MHKDATA\DEMO\LMCOVER.MHK
Page41=MHKDATA\DEMO\LMDEMO.MHK
Page42.r=MHKDATA\DEMO\ABCOVER.MHK
Page43=MHKDATA\DEMO\ABDEMO.MHK
Page44.r=MHKDATA\DEMO\HHCOVER.MHK
Page45=MHKDATA\DEMO\HHDEMO.MHK
Page46.r=MHKDATA\DEMO\BFCOVER.MHK
Page47=MHKDATA\DEMO\BFDEMO.MHK
Page48=MHKDATA\EP\FOO.MHK
Page49=MHKDATA\CP\ABCSONG.MHK

[English.Read]
Page1.r=MHKDATA\ER\ABC_A_ER.MHK
Page2.r=MHKDATA\ER\ABC_B_ER.MHK
Page3.r=MHKDATA\ER\ABC_C_ER.MHK
Page4.r=MHKDATA\ER\ABC_D_ER.MHK
Page5.r=MHKDATA\ER\ABC_E_ER.MHK
Page6.r=MHKDATA\ER\ABC_F_ER.MHK
Page7.r=MHKDATA\ER\ABC_G_ER.MHK
Page8.r=MHKDATA\ER\ABC_H_ER.MHK
Page9.r=MHKDATA\ER\ABC_I_ER.MHK
Page10.r=MHKDATA\ER\ABC_J_ER.MHK
Page11.r=MHKDATA\ER\ABC_K_ER.MHK
Page12.r=MHKDATA\ER\ABC_L_ER.MHK
Page13.r=MHKDATA\ER\ABC_M_ER.MHK
Page14.r=MHKDATA\ER\ABC_N_ER.MHK
Page15.r=MHKDATA\ER\ABC_O_ER.MHK
Page16.r=MHKDATA\ER\ABC_P_ER.MHK
Page17.r=MHKDATA\ER\ABC_Q_ER.MHK
Page18.r=MHKDATA\ER\ABC_R_ER.MHK
Page19.r=MHKDATA\ER\ABC_S_ER.MHK
Page20.r=MHKDATA\ER\ABC_T_ER.MHK
Page21.r=MHKDATA\ER\ABC_U_ER.MHK
Page22.r=MHKDATA\ER\ABC_V_ER.MHK
Page23.r=MHKDATA\ER\ABC_W_ER.MHK
Page24.r=MHKDATA\ER\ABC_X_ER.MHK
Page25.r=MHKDATA\ER\ABC_Y_ER.MHK
Page26.1.r=MHKDATA\EP\ABC_Z1EP.MHK
Page26.2.r=MHKDATA\ER\ABC_Z_ER.MHK
Page27.r=MHKDATA\EP\ABCEND.MHK
Page28=MHKDATA\EP\FOO.MHK
Page29=MHKDATA\DEMO\DEMOPAGE.MHK
Page30.r=MHKDATA\DEMO\JMCOVER.MHK
Page31=MHKDATA\DEMO\JMDEMO.MHK
Page32.r=MHKDATA\DEMO\ATCOVER.MHK
Page33=MHKDATA\DEMO\ATDEMO.MHK
Page34.r=MHKDATA\DEMO\THCOVER.MHK
Page35=MHKDATA\DEMO\THDEMO.MHK
Page36.r=MHKDATA\DEMO\NKCOVER.MHK
Page37.1=MHKDATA\DEMO\NKDEMO1.MHK
Page37.2=MHKDATA\DEMO\NKDEMO2.MHK
Page38.r=MHKDATA\DEMO\RBCOVER.MHK
Page39=MHKDATA\DEMO\RBDEMO.MHK
Page40.r=MHKDATA\DEMO\LMCOVER.MHK
Page41=MHKDATA\DEMO\LMDEMO.MHK
Page42.r=MHKDATA\DEMO\ABCOVER.MHK
Page43=MHKDATA\DEMO\ABDEMO.MHK
Page44.r=MHKDATA\DEMO\HHCOVER.MHK
Page45=MHKDATA\DEMO\HHDEMO.MHK
Page46.r=MHKDATA\DEMO\BFCOVER.MHK
Page47=MHKDATA\DEMO\BFDEMO.MHK
Page48=MHKDATA\EP\FOO.MHK
Page49=MHKDATA\CP\ABCSONG.MHK

Should you need them, I've given you the MD5s for ABC as well.

comment:12 by fuzzie, 7 years ago

Drat. That will teach me not to try bugfixes on computers without sound. I tried moving the playback of the animation in ff1828fc, does that help?

(There's definitely one version of ABC which is using LB 1.x and one which is using LB 2.x. It might be a Windows/Mac difference, though.)

comment:13 by SF/legoking831, 7 years ago

Okay, it seems to be working now. It does it differently in the interpreter (the cursor disappears as soon as you click it on the EXE, whereas here it waits for the animation to make the cursor disappear), but I'd say that's up to you if you feel it's worth fixing, since that's a pretty minor thing and barely hinders anything. I also noticed you can only trigger them once, but that's a bug all on its own and I'll probably just talk about that in another report, since that happens to objects you can click on more than once too, once you've gone through all the animations. For now, you can close this. I'd say this has been resolved.

comment:14 by fuzzie, 7 years ago

Agh. Fixed the multiple-triggers behaviour in bed2eb20. Haven't seen the object behaviour (but you can tell I don't own either ABC nor New Kid, unfortunately), so would appreciate a report on that. Will ponder on the cursor behaviour. Thanks again.

comment:15 by fuzzie, 7 years ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.