Opened 7 years ago

Closed 7 years ago

#6026 closed defect (fixed)

SCI: Detection of SQ4CD as Windows breaks Music

Reported by: digitall Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Space Quest 4

Description

Detection of Space Quest 4 CD from the Space Question Collection CD (and reported by user TMM from the GoG version as well) give the option when detecting and adding game as DOS or Windows.

Choosing DOS i.e. sq4-cd results in correct music output, but choosing Win i.e. sq4-cd-win results in no music output.

This is NOT due to the preferred device not being Adlib Emulator, rather than auto/default.

Replicated on Linux x86_32 with latest Git:
ScummVM 1.5.0git2899-g4d6f287-dirty (Apr 22 2012 17:42:32)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib FluidSynth Theora AAC FreeType2

But user TMM reported it on Windows with v1.4.1 so this is not a recent regression.

Ticket imported from: #3522046. Ticket imported from: bugs/6026.

Change History (3)

comment:1 Changed 7 years ago by digitall

This is probably due to a minor bug in engine/sci/sound/music.cpp associated with the g_sci->_features->useAltWinGMSound() logic i.e. either the Alternative Windows GM Music is not working or missing and fails to fallback to the DOS/normal music if present in that case.

comment:2 Changed 7 years ago by bluegr

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:3 Changed 7 years ago by bluegr

Fixed in e41e412c9ee6c277233ef9f7a5304f8cc40fa370

Note: See TracTickets for help on using tickets.