Opened 7 years ago

Closed 7 years ago

#6024 closed defect (worksforme)

TINSEL: DW1 Static instead of correct SFX running on OSX

Reported by: SF/andybbrown Owned by:
Priority: blocker Component: Engine: Tinsel
Keywords: Cc:
Game: Discworld

Description

ScummVM : version 1.4.1

All of the sound / voices are played as a static noise on my imac G3.
The same game files work flawlessly in 1.4.1 on my PC.

Language of game : English
Version of game : CD/Dos
Platform and Compiler : Mac OS

Ticket imported from: #3521175. Ticket imported from: bugs/6024.

Change History (20)

comment:1 Changed 7 years ago by digitall

Summary: Static noise instead of sound in Discworld on macTINSEL: DW1 Static instead of correct SFX running on OSX

comment:2 Changed 7 years ago by digitall

andybrown: Thank you for this bug report. Please can you report here your exact OS version i.e. OSX 10.3, 10.5, 10.7 ?

Also, could you then test with the latest daily build for OSX found here:
http://buildbot.scummvm.org/builds.html

I have a faint recollection that this bug has been reported before and it may be fixed in this latest development build i.e. out of date.

comment:3 Changed 7 years ago by digitall

Oh, could you also report here:
a) whether your Discworld CD/DOS version has SCN files, GRA files or is GRA Multilingual (3 subvariants which use slightly different code)
and
b) attach a savegame or otherwise document how to replicate the problem... (Though this may just occur from a new game start?)

comment:4 Changed 7 years ago by SF/andybbrown

tdhs: I am using OSX 10.3 my imac G3 is a 350mhz slot loader.

I just tested out the daily build and it still has static noise instead of any sfx / voice acting on my mac.

My CD version has SCN files.

I haven't made a save file, it does this after the first logo instead of playing the sound effect for one of the splash screens, and then when the game starts up its just static for all of the the sound effects / voice acting.

comment:5 Changed 7 years ago by digitall

andybbrown: Thanks for the update.. Could you try with the v1.4.0, v1.3.1, v1.3.0 etc. releases back to 0.9.1 and try to locate if this was a recent breakage?

comment:6 Changed 7 years ago by SF/andybbrown

tdhs: Aha! Works great with ver 1.0, versions 1.1.0 + the sound is all static.

comment:7 Changed 7 years ago by sev-

Priority: normalblocker

comment:8 Changed 7 years ago by sev-

So this is a regression.

It is release critical

comment:9 Changed 7 years ago by digitall

andybbrown: Could you test the latest daily build and confirm if this is still happening?

Since your G3 is PPC and thus Big Endian, this is probably an endian issue in Sound decoding, but trying to find a developer with DW1 SCN version and a PPC Mac is proving tricky.

If you have time and are capable, getting a Git checkout of our codebase, compiling and running a bisection for the point of regression between 1.0 and 1.1.0 would be very useful. The instructions here should help you with getting the code and compiling on OSX:
http://wiki.scummvm.org/index.php/Git#Retrieving_the_code
http://wiki.scummvm.org/index.php/Compiling_ScummVM

comment:10 Changed 7 years ago by criezy

I tried replicating with the demo as I don't have the full game, but speech works well for me with both 1.4.0 and the latest PPC MacOS X 1.5.0git nightly. Possibly this is because the demo is the GRA version.

comment:11 Changed 7 years ago by criezy

Precision on my last comment: this is on a G3 300 MHz iBook with MacOS X 10.3.9 (so pretty similar to the one the reported has).
Also the tests were done with 1.4.1 and current nightly (not 1.4.0 as I mistakenly wrote - that version doesn't even start on MacOS X 10.3)

comment:12 Changed 7 years ago by SF/andybbrown

I can confirm that the voice is still static in the latest nightly build for PPC on my imac.

Sorry, but I don't think I can handle compiling a build, but if there is a way for me to get that compiled version for PPC I am willing to try it out.

comment:13 Changed 7 years ago by digitall

andybbrown: Okay... different approach.
1. Can you download the DW1 DOS CD Demo from here and try that to see if the same problem occurs:
https://sourceforge.net/projects/scummvm/files/demos/tinsel/dw-dos-cd-demo-en.zip/download
2. Can you be clear if the music is affected as well... or just SFX/Speech?

comment:14 Changed 7 years ago by SF/andybbrown

The music works just fine, it's only the speech that plays as static. Downloading the demo now, will report back once it's finished and I've tried it out.

comment:15 Changed 7 years ago by SF/andybbrown

Just tried the demo version and the GRA files seem to work fine for the voices and sfx.

comment:16 Changed 7 years ago by digitall

andybbrown: OK.. We need to verify the exact version of your DW1 CD datafiles and eliminate the possibility of datafile corruptions. Can you attach a file listing of your DW1 CD datafiles to this bug, along with file MD5sums as a text file attachment?

The output of a tool such as http://md5summer.org/ would be optimal, but on OSX, you should be able to do this from the command line, though you may need to install the tools if they are not present:
http://raamdev.com/2008/howto-install-md5sum-sha1sum-on-mac-os-x/

comment:17 Changed 7 years ago by digitall

Setting bug to pending as can't continue investigation without information from the bug submitter.
If no response is received within 14 days, the bug will automatically be closed.

comment:18 Changed 7 years ago by digitall

Resolution: worksforme
Status: newpending

comment:19 Changed 7 years ago by bluegr

This has not been closed automatically, and it's pretty old now. Closing manually.

comment:20 Changed 7 years ago by bluegr

Status: pendingclosed
Note: See TracTickets for help on using tickets.