Opened 8 years ago

Closed 8 years ago

Last modified 6 years ago

#6023 closed defect (fixed)

CATALOG2: Humongous catalog different version not recognized

Reported by: SF/legoking831 Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: detection Cc:
Game:

Description

ScummVM 1.4.1 (Jan 18 2012 10:48:28)
This is the movie theater-styled version of the Humongous catalog. One version is already supported, and I\'m sure it\'s the one everybody knows about. There\'s an extremely rare second version, though, and includes an extra screen with the classic demos. Never heard of it? I don\'t blame you in the slightest. Here\'s the error given:
Your game version appears to be unknown. If this is *NOT* a fan-modified version (in particular, not a fan-made translation), please, report the following data to the ScummVM team along with the name of the game you tried to add and its version/language/etc.:
SCUMM gameid \'catalog\', file \'catalog2.he0\', MD5 \'f7635a0e2ab82c9a0f9ace5f232a488f\'

readMAXS(40) failed to read the MAXS data!

The version without the classics appears to be detected correctly, and runs fine. I also tried this on a nightly build, same error. The MAXS data error is to be expected, given that it\'s trying to read the MAXS data of the other version.
Download the catalog: http://speedy.sh/EEvBA/CATALOG2.zip
Language: English
Platform: Win32

Ticket imported from: #3520792. Ticket imported from: bugs/6023.

Change History (3)

comment:1 by Kirben, 8 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:2 by Kirben, 8 years ago

I added the game demo details to ScummVM GiT, use the current Windows snapshot of ScummVM GiT.

comment:3 by Strangerke, 6 years ago

Component: --Unset--Engine: SCUMM
Note: See TracTickets for help on using tickets.