Opened 8 years ago

Closed 8 years ago

#6002 closed defect (fixed)

IPHONE: Monkey2 crashes in alley

Reported by: lordhoto Owned by: wjp
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

Tested with: 1.4.1 and latest master (b71dffafbe438a5cea887ae3f72ef76dd5d00cd9)
On: iPhone 3G 8GB

When entering the back alley on Phatt Island ScummVM just crashes. This happens nearly all of the time, once or twice in over 30 tries it worked though.

I attached a savegame of the German DOS version. It can also be reproduced with the English version via boot param 667.

(Partly) symbolicated crash log for the thread crashing with a SIGSEGV:

Thread 0:
0 libSystem.B.dylib 0x35d5b3b0 mach_msg_trap + 20
1 libSystem.B.dylib 0x35d5d894 mach_msg + 60
2 CoreFoundation 0x37521f7c __CFRunLoopServiceMachPort + 88
3 CoreFoundation 0x37521780 __CFRunLoopRun + 400
4 CoreFoundation 0x37521504 CFRunLoopRunSpecific + 220
5 CoreFoundation 0x37521412 CFRunLoopRunInMode + 54
6 GraphicsServices 0x33e76d1c GSEventRunModal + 188
7 UIKit 0x3591d574 -[UIApplication _run] + 580
8 UIKit 0x3591a550 UIApplicationMain + 964
9 ScummVM 0x00007464 0x1000 + 25700
10 ScummVM 0x00002754 0x1000 + 5972
11 ScummVM 0x000025f0 0x1000 + 5616

Ticket imported from: #3500023. Ticket imported from: bugs/6002.

Attachments (1)

monkey2.s04 (34.3 KB ) - added by lordhoto 8 years ago.

Download all attachments as: .zip

Change History (5)

by lordhoto, 8 years ago

Attachment: monkey2.s04 added

comment:1 by lordhoto, 8 years ago

I tried fuzzie's suggestion and disabled the ARM assembly. Afterwards I couldn't reproduce the crash anymore. So I suspect there might be some memory corruption going on there. I will try whether I can track it down to one specific ARM assembly feature.

comment:2 by lordhoto, 8 years ago

It turns out the crash starts to happen, when I enable USE_ARM_COSTUME_ASM, so the problem is probably somewhere in ClassicProc3RendererShadowARM.

comment:3 by digitall, 8 years ago

Owner: set to wjp
Resolution: fixed
Status: newclosed

comment:4 by digitall, 8 years ago

This bug was fixed by wjp in commit a6ba9f150a19765956d4fb9ba750782f05f74f48. Closing as fixed.

Note: See TracTickets for help on using tickets.