Opened 8 years ago

Closed 7 years ago

#5995 closed defect (invalid)

SCI: LB1-Amiga crashes at the end of the introduction

Reported by: OmerMor Owned by: bluegr
Priority: high Component: Engine: SCI
Keywords: Cc:
Game: Laura Bow 1: The Colonel's Bequest

Description

ScummVM version: 1.5.0git2536-gad9fdfd (Feb 14 2012 10:01:40)
Platform: Win7 32bit
Game version: Amiga
Interpreter version (from executable file): 1.002.030
Language: English

Repro:
run the game
watch intro
after Lillian and Laura retire to their room, the game crashes.

The following is what's written to the console:

User picked target 'laurabow-amiga' (gameid 'sci')...
Looking for a plugin supporting this gameid... SCI [SCI0, SCI01, SCI10, SCI11, SCI32]
Starting 'Sierra SCI Game'
WARNING: Error 5 occurred while reading font.390 from resource file resource.003: No resource files found!
WARNING: resMan: Failed to read font.390!
view resource 925 not found!

I checked my game files and verified (using SCI Resource Viewer) that view 925 (925.v16) is present inside resource.004. The view is the head of Laura's father.
There is no font.390 resource in the game, but I don't think this caused the crash.

Ticket imported from: #3493376. Ticket imported from: bugs/5995.

Attachments (1)

Colonel's Bequest.md5 (1.3 KB ) - added by OmerMor 8 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 by OmerMor, 8 years ago

Summary: Amiga version crashes at the end of the introductionSCI: LB1-Amiga crashes at the end of the introduction

comment:2 by digitall, 8 years ago

omer_mor: Thank you for the bug report.
In order to progress this, we need to rule out corrupt datafiles and identify your exact version.

Please can you attach a text file to this bug containing a listing of your LB1 Amiga datafiles with file sizes and file MD5sums. The output of a tool such as http://md5summer.org/ would be optimal.

by OmerMor, 8 years ago

Attachment: Colonel's Bequest.md5 added

comment:3 by OmerMor, 8 years ago

Attached.

If you need specific resources (like the crashing script) I can extract and upload these as well.

comment:4 by bluegr, 8 years ago

I cannot replicate this with my version, and the whole situation sounds like you got corrupted game files. Try copying the game files again from the original disks or download the game (legally) from back2roots.org

comment:5 by bluegr, 8 years ago

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:6 by bluegr, 8 years ago

Owner: set to bluegr
Resolution: invalid
Status: newpending

comment:7 by OmerMor, 8 years ago

Status: pendingnew

comment:8 by OmerMor, 8 years ago

The disks I checked were from back2roots.
I tried checking my original Amiga floppies and scummvm works fine.
I compared the resources and the only difference is in resource.003.
SCI Viewer cannot parse this resource file which could explain why scummvm would crash there as well (the script it tries to run at the crashing point is from resource.003).
So corrupt resource it is.
What is left unexplained is how the original amiga sci interpreter overcome this corrupt resource.
This is can be easily reproduced by downloading the version from back2roots and running the intro to its end.

comment:9 by bluegr, 8 years ago

Are you sure that the original interpreter handles these files? Did you try it with UAE, for example?

back2roots has some other games with corrupted resources (e.g. the SCI1 version of LSL1). It would be great if you sent a message to back2roots, sending them your fixed copy of the game :)

comment:10 by OmerMor, 8 years ago

I can confirm that the "corrupted" version works fine via WinUAE.

comment:11 by sev-, 7 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:12 by sev-, 7 years ago

Priority: normalhigh

comment:13 by bluegr, 7 years ago

(Note: The affected room is 44)

comment:14 by bluegr, 7 years ago

Status: newclosed

comment:15 by bluegr, 7 years ago

There is not much that can be done here, I'm afraid. The resource files are corrupted, and the SCI resource manager ignores the corrupted ones, because it detects an error in the file compression. I don't see why we should force the resource manager to accept broken resource files on purpose, since the corrupt files will trigger all sorts of crashes later on.

As mentioned already, the game disks in BTTR are corrupted. New correct ones should be sent to BTTR. We won't force the engine to accept broken resource files which will likely cause issues with the game later on.

Closing as invalid.

Note: See TracTickets for help on using tickets.