Opened 7 years ago

Closed 7 years ago

#5965 closed defect (fixed)

SCI: Space Quest 3: Minor graphics problem in intro

Reported by: SF/renzt Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Space Quest 3

Description

This bug is in the intro of Space Quest 3. It's a pretty minor issue, but a bug's a bug.

In the intro, when the escape pod is floating across the screen crosshairs will be drawn on the screen, centered on the pod. The bug is that in ScummVM the crosshairs start in the center of the screen and are drawn towards the edges.

The expected behaviour is that they start on the edges of the screen and are drawn towards the center (verified in dosbox, but I also remember it from an actual dos machine).

- Win32
- ScummVM version: 1.5.0git2190-ga488556 ( Feb 3 2012 05:42:16 )
- also noticed in 1.4.0 and 1.4.1, not sure about earlier versions
- DOS/English
- SQ3 version 1.018, from Space Quest Collection (1997)

Easy repro steps for this one, just start the game and watch the intro.

Ticket imported from: #3485194. Ticket imported from: bugs/5965.

Change History (5)

comment:1 Changed 7 years ago by digitall

Replicated on Linux x86_32 with latest Git master. Running with ./scummvm -d 5 --debugflags=Graphics gives this at the relevant point in time of the graphical difference:
NumCels(view.1, 0) = 1
Transition 6, blackout 0
NumCels(view.1, 1) = 2

comment:2 Changed 7 years ago by digitall

Confirmed that original interpreter under DOSBox shows the "crosshairs" being drawn from the outside of the screen to the center outline of the ship i.e. the opposite of our current behaviour.

comment:3 Changed 7 years ago by digitall

Aha!... This looks like an issue with the Transition type.
Type 6 is SCI_TRANSITIONS_DIAGONALROLL_FROMCENTER, rather than SCI_TRANSITIONS_DIAGONALROLL_TOCENTER (which is type 7).

This may be an issue of SCI1Late/Early etc. with SQ3...

comment:4 Changed 7 years ago by bluegr

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:5 Changed 7 years ago by bluegr

Indeed, the transition table entries were reversed - this was apparent with other SCI0 games, too (e.g. Hoyle 1 and ICEMAN).

Thanks tdhs for the finding :) Bug fixed in 7da29858.

renzt, thanks for the bug report, please download the latest daily version for a fix for this bug

Note: See TracTickets for help on using tickets.