Opened 17 years ago

Closed 16 years ago

Last modified 16 years ago

#595 closed defect (fixed)

LOOM: Bobbin walks on the spot

Reported by: fingolfin Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

Immediatly at the start of the game, double click the
leave. Bobbin will start walking on the spot.

Maybe this is yet another walkbox 0 issue? I really am
tempted to rewrite the whole actor walking code for
OLD256/SHORTHEADER games - apparently, they marked the
"invalid" box as -1, we should do that, too.

Alas, the cause of this bug is maybe completly
unrelated :-)

Ticket imported from: #644750. Ticket imported from: bugs/595.

Change History (8)

comment:1 Changed 17 years ago by fingolfin

Summary: LOOM: Bobbing walks on the spotLOOM: Bobbin walks on the spot

comment:2 Changed 17 years ago by eriktorbjorn

I couldn't reproduce the exact bug (with yesterday's CVS
snapshot), though by clicking at random around the cliff, I
could sometimes get Bobbin to walk on the spot.

Since I had to work to get the bug to happen, I'm not going
to lose any sleep over it. :-)

comment:3 Changed 17 years ago by fingolfin

I correct myself: the bug is indeed not keyed to the leaf,
but I can reproduce it easily anyway (still same place):
1) click on some spot to make Bobbin walk there; don't move
your mouse
2) Note into which direction Bobbin is facing
3) Move your mouse a few pixels into the opposite direction
4) Double click on the spot

The goal is to get Bobbin to turn, but not take a step.
That's in fact what he does. But with the double click, he
turns and starts to walk on the spot. I can get the bug to
show with the above trick 90% of the time (the other times I
click to far away/too close/not fast enough :-)

comment:4 Changed 17 years ago by fingolfin

In fact it even works without the turn, if I double click
just in front of Bobbin it also happens. You ahve to
experiment a bit to get the hang of it, if you click to far
away or too close it won't work.

comment:5 Changed 16 years ago by fingolfin

Still occurs in latest CVS.

comment:6 Changed 16 years ago by SF/segra

This also occurs in Zak256, i can produce it by clicking
around the draw in the first room with the kazoo in it.

comment:7 Changed 16 years ago by fingolfin

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:8 Changed 16 years ago by fingolfin

This is fixed in CVS

Note: See TracTickets for help on using tickets.