Opened 17 years ago

Closed 17 years ago

Last modified 13 months ago

#594 closed defect (fixed)

ALL: Text output bug

Reported by: SF/dfabulich Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

Lots of dialog text in this game is wrapping
incorrectly; lines of text are getting clipped. (This
was working as of very recently, but I can't swear as
to when.)

To reproduce, start the game afresh and hit ESC twice.
Indy should say "I'm back!" and Kerner will give the
line: "You don't look at all well, Dr Jones" but the
line will be clipped. Many other long lines will also
be clipped throughout the game. A screenshot is attached.

I'm using English Talkie CD, files copied to the
harddrive. I'm on Win2K using the latest Win32
snapshot: ScummVM 0.2.82 CVS Built on Nov 27 2002 12:09:16

Ticket imported from: #644620. Ticket imported from: bugs/594.

Attachments (1)

dialogbug.png (100.1 KB ) - added by SF/dfabulich 17 years ago.
Screenshot of clipped line

Download all attachments as: .zip

Change History (8)

by SF/dfabulich, 17 years ago

Attachment: dialogbug.png added

Screenshot of clipped line

comment:1 by eriktorbjorn, 17 years ago

It affects other games, as well, e.g. the MI1 intro. It's as
if the letters are spaced a bit further apart than they used
to be. At first I thought it was Fingolfin's string.cpp
cleanup, but I don't see any obvious errors in it... I'll
have to take a closer look later today.

comment:2 by fingolfin, 17 years ago

I also looked over my cleanup and it seems fine - I really
only restructured some stuff. Doesn't mean I made a mistake
doing so, of course.

comment:3 by fingolfin, 17 years ago

Can you narrow down since when this happens?

comment:4 by fingolfin, 17 years ago

Component: Engine: SCUMM--Unset--
Game: Indiana Jones 4
Owner: set to fingolfin
Summary: FOA: Dialog bugALL: Text output bug

comment:5 by fingolfin, 17 years ago

Resolution: fixed
Status: newclosed

comment:6 by fingolfin, 17 years ago

Found it! Accidentally used "true" instead of "false"

comment:7 by digitall, 13 months ago

Component: --Unset--Engine: SCUMM
Game: Indiana Jones 4
Note: See TracTickets for help on using tickets.