Opened 9 years ago

Closed 9 years ago

#5938 closed defect (fixed)

TSAGE: BF: Saving/loading while in map crash

Reported by: tsoliman Owned by: Strangerke
Priority: normal Component: Engine: TsAGE
Keywords: Cc:
Game: Blue Force

Description

If you save when the map is up and then load the save, visit the police station (there's no text for it, you kind of click where you know it is), the game crashes because it tries to load scene 0 Unknown scene number - 0!

Linux adb534

Ticket imported from: #3467502. Ticket imported from: bugs/5938.

Attachments (1)

blueforce-cd.005 (24.8 KB ) - added by tsoliman 9 years ago.

Download all attachments as: .zip

Change History (8)

by tsoliman, 9 years ago

Attachment: blueforce-cd.005 added

comment:1 by tsoliman, 9 years ago

Summary: TSAGE: BF: Saving/loading while in mapTSAGE: BF: Saving/loading while in map crash

comment:2 by digitall, 9 years ago

Replicated with Linux x86_32 and latest Git master with attached savegame. Will bisect to see if this is a recent regression.

comment:3 by digitall, 9 years ago

As far as I can tell, this has always happened when loading on the map screen and loading from launcher or in game (F5/F7) makes no difference. Looks like some of the game state is not restored correctly on load / not saved...

comment:4 by Strangerke, 9 years ago

Should be fixed in b59b703f721d4a52b1e73084294d44976419fead. Impacted savegames are corrupted, please test with a new savegame.

comment:5 by Strangerke, 9 years ago

Resolution: fixed

comment:6 by digitall, 9 years ago

Tested with latest Git master with new savegames. This is now fixed. Thanks Strangerke.

Closing bug...

comment:7 by digitall, 9 years ago

Owner: set to Strangerke
Status: newclosed
Note: See TracTickets for help on using tickets.