Opened 9 years ago

Closed 9 years ago

#5937 closed defect (fixed)

TSAGE: BF: Graphics weirdness and overwriting in map

Reported by: tsoliman Owned by: dreammaster
Priority: normal Component: Engine: TsAGE
Keywords: Cc:
Game: Blue Force

Description

I am getting a weird graphics overwrite the very first time I use the map when you scroll right and left. I cannot properly screenshot it. Here's a save just before it.

Linux adb534

Ticket imported from: #3467501. Ticket imported from: bugs/5937.

Attachments (2)

blueforce-cd.006 (13.4 KB ) - added by tsoliman 9 years ago.
Use ignition and then scroll map
bf-map-gfx-glitch.png (82.5 KB ) - added by digitall 9 years ago.
Observed GFX Glitch

Download all attachments as: .zip

Change History (10)

by tsoliman, 9 years ago

Attachment: blueforce-cd.006 added

Use ignition and then scroll map

comment:1 by digitall, 9 years ago

I can replicate this with Linux x86_32 on current Git master: b89bc000d96fce9d4e977b8ad59391282e35704e

Attaching a screenshot of my observed graphics glitch which is a large black vertical block when scrolling horizontally... Looks like an issue with calculation of scroll redraw width. This is a regression as this didn't happen with my previous playthrough. No associated valgrind issues. Will attempt to bisect.

by digitall, 9 years ago

Attachment: bf-map-gfx-glitch.png added

Observed GFX Glitch

comment:2 by digitall, 9 years ago

Owner: set to dreammaster

comment:3 by digitall, 9 years ago

This regression was introduced by: commit f69dfba21a5d4be8cc60a20a0dd0628717fa5373 Author: Paul Gilbert <dreammaster@scummvm.org> Date: Sun Dec 18 18:08:45 2011 +1100

TSAGE: Implemented dirty rect handling in the engine

This should help improve performance when scalers are being used.

dreammaster: Can you take a look at this?

comment:4 by digitall, 9 years ago

dreammaster: N.B. The clipping of part of the "pop-up" HUD/inventory in the map screen when scrolling left and right (normally part of the right side of this) was present prior to the dirty rects change and isn't related... Not sure if this was present in the original...

comment:5 by dreammaster, 9 years ago

I've just done some commits which fixes the dirty rect handling, with the result that you'll no longer get those black areas on wide screens.

As for the inventory area, it's not meant to show the inventory area on the map screen. Since you say it was present prior to the commit for dirty rect handling, could you provide the steps you go through to make it appear? When I try going to the map screen the inventory area is correctly hidden.

comment:6 by digitall, 9 years ago

Can't replicate this anymore... Probably fixed by dirty rects reversion (and I was wrong).

comment:7 by digitall, 9 years ago

Resolution: fixed
Status: newclosed

comment:8 by digitall, 9 years ago

The reported bug is now fixed... Closing.

Note: See TracTickets for help on using tickets.