Opened 17 years ago

Closed 16 years ago

Last modified 12 months ago

#588 closed defect (invalid)

MI2: Custom MT32 instrument warnings

Reported by: SF/jsaathof Owned by: SF/jamieson630
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

Monkey Island 2 is playable through the end. However the
following warnings are displayed on my terminal:

WARNING: Could not find appropriate GM program for
MT-32 custom instrument "Fire Pit "!

WARNING: Could not find appropriate GM program for
MT-32 custom instrument "jacob's la"!

WARNING: Could not find appropriate GM program for
MT-32 custom instrument "SdTrk Bend"!

WARNING: Could not find appropriate GM program for
MT-32 custom instrument "thnderclap"!

WARNING: Could not find appropriate GM program for
MT-32 custom instrument "rope fall "!

WARNING: Could not find appropriate GM program for
MT-32 custom instrument "foghorn "!

WARNING: Could not find appropriate GM program for
MT-32 custom instrument "dinkfall "!

WARNING: Could not find appropriate GM program for
MT-32 custom instrument "ML explosn"!

WARNING: Could not find appropriate GM program for
MT-32 custom instrument "rumble "!

IMuseInternal::findTag completely failed finding sound 65
WARNING: SE::start_sound failed: Couldn't find sound 65!

IMuseInternal::findTag completely failed finding sound 67
WARNING: SE::start_sound failed: Couldn't find sound 67!

IMuseInternal::findTag completely failed finding sound 22
WARNING: SE::start_sound failed: Couldn't find sound 22!

IMuseInternal::findTag completely failed finding sound 15
WARNING: SE::start_sound failed: Couldn't find sound 15!

IMuseInternal::findTag completely failed finding sound 9
WARNING: SE::start_sound failed: Couldn't find sound 9!

IMuseInternal::findTag completely failed finding sound 33
WARNING: SE::start_sound failed: Couldn't find sound 33!

IMuseInternal::findTag completely failed finding sound 32
WARNING: SE::start_sound failed: Couldn't find sound 32!

I use a CVS version from a week ago on a Linux system
using Alsa midi sound.

Jurriaan

Ticket imported from: #642895. Ticket imported from: bugs/588.

Change History (11)

comment:1 by fingolfin, 17 years ago

Please always use latest CVS when you report bugs.
Development is often very fast, and a week is a long period
of time.

comment:2 by fingolfin, 17 years ago

Owner: set to SF/jamieson630

comment:3 by SF/jamieson630, 17 years ago

Ref Patch #637825. We are in the process of building a
library of MT-32 custom instrument definitions used by MI2
and FOA. Until the library is complete, the game will warn of
any unsupported custom instruments.

The sound issue, I believe, is related to music tracks that are
implemented only in Adlib, and have no GM equivalent. I will
double-check that hypothesis when I have a bit more time.

In the meantime, be aware that the best way to play MI2 is
with the -eadlib option, rather than the -ealsa option. MI2 was
designed to be used with Adlib.

comment:4 by SF/jamieson630, 17 years ago

Priority: normallow

comment:5 by SF/jamieson630, 17 years ago

By "sound issue", I meant the IMuseInternal::findTag and
IMuseInternal::start_sound errors. Just for clarification.

comment:6 by SF/jamieson630, 17 years ago

Summary: MI2: MT32 instruments & iMuse soundsMI2: Custom MT32 instrument warnings

comment:7 by SF/trinity78, 16 years ago

I finished Indiana Jones 4 today, here is a complete list of all
missing MT32- Instruments:

Fzooom, ghostwhosh, Fire Pit, squirel, *whip3, *woodknock,
mtlheater1, boom15, scrape2, gloop2, boxclika1, Mellow str,
Arabongo, *ooh!, *aah!, *shotFar4, carstart, crsrt/idl3,
gunShotNea, stonewheel6, spindle4, chains, street, knife,
rockcrunch, splash2, 35 lavabub, pachinko5, runngwatr,
idoorclse, celldoor, boom10, Fzooom 2, lavacmbl4, boom11,
bodythud1

comment:8 by fingolfin, 16 years ago

Well, IMHO: it's not a bug, it's a feature (request)... or rather, a TODO
item, isn't it?

comment:9 by SF/jamieson630, 16 years ago

Yes, nothing here constitutes a bug to my knowledge.
Closing. The only thing on the TODO list, in the meantime, is
to mute MIDI channels that use an unsupported custom MT-
32 instrument. Once that's done, the warnings for bad
instruments will be removed.

comment:10 by SF/jamieson630, 16 years ago

Resolution: invalid
Status: newclosed

comment:11 by digitall, 12 months ago

Component: Engine: SCUMM
Game: Monkey Island 2
Note: See TracTickets for help on using tickets.