Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5846 closed defect (fixed)

SCI: Longbow: Robin is stuck in the final monk chase scene

Reported by: bluegr Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Conquests of the Longbow

Description

There seems to be a bug in the scene where monks chase Robin with rocks right before the end (scene 710).

Robin is supposed to be escaping from the monks in the monastery, who throw rocks at him, while he's climbing down a wall. In ScummVM, he can't climb down the wall. Also, the monks only throw one rock, which goes off screen (not down the wall, and it never bounces on the wall) and seems to be falling forever. Thus, the game is effectively stuck.

I am not sure what is wrong... I tend to believe that this is a pathfinding problem, though this is just speculation. This is likely a regression, as people that the game is completable in the past. It might be caused by the recent changes to kInitBresen/kDoBresen. I haven't bisected to check which commit broke it.

Here's what it's supposed to look like: http://www.youtube.com/watch?v=TuT9oxD-AR0#t=6m18s

Ticket imported from: #3413020. Ticket imported from: bugs/5846.

Change History (5)

comment:1 by bluegr, 9 years ago

Also, you only need to teleport to scene 710 - no save is necessary

comment:2 by bluegr, 9 years ago

Status: newclosed

comment:3 by bluegr, 9 years ago

Fixed in r0b4802c Special thanks to wjp for his work on bisecting to find the regression and for checking against the KQ5CD disasm.

comment:4 by bluegr, 9 years ago

Owner: set to bluegr
Resolution: fixed

comment:5 by bluegr, 9 years ago

A regression from 1b9d95e43c1dce369d8a929ede4b144290729e96 (kRandom rewrite)

Note: See TracTickets for help on using tickets.