Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5845 closed defect (fixed)

SCI: LL 6-Crash when loading Savegame - room 620, script 85

Reported by: SF/lichtamberg Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: script Cc:
Game: Leisure Suit Larry 6

Description

Hey,

i saved my game and tried to load it afterwards but there is always an error message:

ERROR[VM] kGraph(RestoreBox): signature mismatch via method IScroller::hide (room 620, script 85, localCall ff

I tried it with all available versions of scummvm: 1.3.0, 1.3.1 and dailybuild 1.4.0git2390-g64e0ba (Sep 20 2011 04:24) - My system is OSX 10.6 Snow Leopard

I've added my savegame as a zipfile.

Hope you can reproduce and fix it?

Ticket imported from: #3412002. Ticket imported from: bugs/5845.

Attachments (2)

lsl6.000 (40.5 KB ) - added by digitall 8 years ago.
Savegame For Replication
ll6-filenames.txt (6.4 KB ) - added by SF/lichtamberg 8 years ago.
MD5 hashes for ll6 files

Download all attachments as: .zip

Change History (11)

comment:1 by SF/lichtamberg, 8 years ago

Summary: Crash when loading Savegame - room 620, script 85SCI: LL 6-Crash when loading Savegame - room 620, script 85

by digitall, 8 years ago

Attachment: lsl6.000 added

Savegame For Replication

comment:2 by digitall, 8 years ago

Removed the zipfile, since the savegame in question was smaller than the SF.net attachment limit and attached just the savegame file.

Replicated the described engine abort using the attached savegame on Linux x86_32 with the latest v1.4.0 Git master.

lichtamberg: This will require a SCI dev to look at the scripts for this, which may take some time. Please standby...

comment:3 by digitall, 8 years ago

lichtamberg: One thing: SCI games do vary somewhat.

Could you reply here describing exactly what version you have i.e. CD, Floppy, Compilation or GoG digital download?

Also, if you can attach a textfile listing filenames and MD5sums of your LSL6 datafiles that will help us ensure that your copy is not corrupted and will give us exactly which patches have been installed.. There are a number of free tools to do this.

comment:4 by wjp, 8 years ago

The full error message is:

parameter 0: 0036:0001 (error), should be null, reference, invalid
[VM] kGraph(RestoreBox): signature mismatch via method lScroller::hide (room 620, script 85, localCall ffffffff)!

comment:5 by wjp, 8 years ago

By the way, we now have multiple workarounds in place (in LSL6 and GK1 at least) that catch parameters of type "error" where parameters of type "invalid" _are_ accepted. This feels a bit weird, since SCI didn't have that distinction.

by SF/lichtamberg, 8 years ago

Attachment: ll6-filenames.txt added

MD5 hashes for ll6 files

comment:6 by SF/lichtamberg, 8 years ago

I attached a file with the md5 sums and the game was an internet download.

Thanks for your help!

comment:7 by bluegr, 8 years ago

Status: newclosed

comment:8 by bluegr, 8 years ago

Fixed in b807041ad2

comment:9 by bluegr, 8 years ago

Keywords: script added
Owner: set to bluegr
Resolution: fixed
Note: See TracTickets for help on using tickets.