Opened 8 years ago

Closed 8 years ago

#5777 closed defect (fixed)

Hugo 1 won't start in Windows CE 5.0

Reported by: SF/klasno-001 Owned by: CeRiAl
Priority: normal Component: Engine: Hugo
Keywords: Cc:
Game: Hugo

Description

In the latest WinCE release version, V 1.3.0, the launcher recognizes Hugo 1: Hugo's House of Horrors (DOS/English), but when I press start, the game will not start. The purple and black screen pops up without any words, and then a Windows CE "Fatal Application Error" message displays saying ScummVM performed an illegal operation and will be shut down. This happens each time I try to start Hugo, but it does not happen for other games that I have tested.

If it is useful, I have an old daily build, it is "ScummVM 1.3.0svn53560" from October 18, 2010 which does start the game without this error. However this old daily build doesn't play sound and will not play beyond the first screen. If you need any other information, I am ready to help in any way I can.

Thank you for your efforts on this great port!

Ticket imported from: #3332002. Ticket imported from: bugs/5777.

Change History (9)

comment:1 by SF/klasno-001, 8 years ago

Owner: set to CeRiAl

comment:2 by digitall, 8 years ago

klasno-001: Please can you test with the v1.3.1 release to see if this problem has been corrected for you.
If not, please can you repeat this test with the latest development daily build to see if this problem has been fixed by v1.4.0pre (Note: Development, _not_ Stable):
http://buildbot.scummvm.org/builds.html

comment:3 by CeRiAl, 8 years ago

tdhs: I just made a few tests, and sadly I have to confirm that the bug is still present 1.3.1.
Strangely, this problem is gone in the current 1.4.0pre unstable version (as the Teenagent crash is). I suppose that there was a problem with the engine itself as I myself didn't fix anything in the unstable branch related to this bug. I will try to find out what exactly causes this problem.

comment:4 by digitall, 8 years ago

cerial23: Looking at the changes to engine/hugo since the branch-1-3 point, it might be caused by:
d21402ef3c39e8a4664e36417d8192208a21b148 HUGO: Fix incorrect usage of sizeof

I would suggest that you try using "git bisect" on the master branch looking for when the breakage was fixed as this is less obviously clear than the Teenagent issue. Both of these may have been fixed by the Graphics::Surface changes rather than the commits I have indicated, but a bisection and test of builds on WinCE will be the only way to confirm this.
Thanks for looking at this.

comment:5 by CeRiAl, 8 years ago

tdhs: After a lot of recompiling and testing I finally found the commit which fixed Hugo1:
7a882600c6778ad7d0bd GRAPHICS: Allocate Common::PEResources on the heap in WinFont::loadFromPE()

I've already applied this patch to branch-1-3 and just tested the resulting binary from builtbot (nightly-stable) and it works nicely now.

klasno-001: Could you please confirm that the current nightly-stable version (http://buildbot.scummvm.org/builds.html) fixes this problem for you, too?

comment:6 by CeRiAl, 8 years ago

Resolution: fixed

comment:7 by digitall, 8 years ago

Since this issue is fixed, I will set this item pending such that with no response from user, it will be automatically closed in 14 days.

comment:8 by digitall, 8 years ago

Status: newpending

comment:9 by CeRiAl, 8 years ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.