Opened 8 years ago

Closed 8 years ago

Last modified 5 years ago

#5776 closed defect (worksforme)

Android: No right-click menu in FT

Reported by: SF/cjatcti Owned by: dhewg
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Full Throttle

Description

On my HTC Desire HD there is no option for a right click to get the Hand/Face/Boot menu. No external camera button, there has been posting sugestions of long touch or double click, but currently they don't work on 1.3.0 version with the Market add in loaded.
The best i get is a flash of the menu.

Is there a fix?

Ticket imported from: #3331336. Ticket imported from: bugs/5776.

Change History (12)

comment:1 by digitall, 8 years ago

Owner: set to dhewg

comment:2 by digitall, 8 years ago

cjactcti: Please read through the following as it describes the input control system:
https://github.com/scummvm/scummvm/blob/master/dists/android/README.Android

It seems other people have had issues with the right click, hold down and slide to the required option control in FT, but it _is_ possible:
http://forums.scummvm.org/viewtopic.php?t=10264&sid=8b9442580422ca3b896a21dc60d9b334

Reading through this, may also be of help:
http://forums.scummvm.org/viewtopic.php?t=10066&sid=8b9442580422ca3b896a21dc60d9b334

If this still does not help, please try downloading the latest daily build and seeing if the control system there works:
http://www.scummvm.org/downloads/#daily

If you could update this bug with the results of this i.e. whether you can now control FT fine, or whether there is a "real" issue here.. Thanks.

comment:3 by SF/cjatcti, 8 years ago

Hello,
Looking at for Touchscreen right click: https://github.com/scummvm/scummvm/blob/master/dists/android/README.Android
Tap held for >0.5s without movement: nothing
Two finger tap: Right mouse button click nothing

Looking at the other links, one is a work around for a constant Right click section, the other says it worked at that time on that phone.

I will try the "daily build" & see if it's got unbroken.

comment:4 by SF/cjatcti, 8 years ago

Looking in more detail, The phone where it worked has a camera button, when I click my search button Ben says "I don't have anything" - which is left click responce, not the Right click show menu option

comment:5 by dhewg, 8 years ago

Summary: No Menu in AndroidAndroid: No right-click menu in FT

comment:6 by dhewg, 8 years ago

To prevent input delays the double tap is a little "special", which ends in a left click for the first tap, and a right click for the 2nd. That makes FT ignore the latter, I'll look into possible solutions.
What hardware buttons does the phone have?

comment:7 by SF/cjatcti, 8 years ago

LIke all HTC it has as proper buttons 1) Power & 2) Volume Up/Down rocker on side (bottom when playing game) plus the 4 Google touch base of screen - Home, Menu, back, & search.

For me Left Click is tap screen Right is Tap & long hold (why currently it's middle button when most mice don't have one) or/& search button as it doesn't need to do anything else.

All the best

comment:8 by dhewg, 8 years ago

Wait, I confused stuff with The Dig on my last comment.

What you want is drag&drop!
Try this:
Double Tap, but hole the 2nd down. The menu should appear then

comment:9 by SF/cjatcti, 8 years ago

Thank You,

It does work but, a) How would I guess that? b) I often have to do it twice to get it to work, & c) I can see why the bike fight section becomes impossible - it was hard enough on PC.

Pretty please with sugar on, can you make it work for the search button

All the best

Andrew CJ

comment:10 by dhewg, 8 years ago

Resolution: worksforme
Status: newclosed

comment:11 by dhewg, 8 years ago

well, you have to know that you have to hold down the left mouse button to play FT. And this touchpad implementation is described in README.Android.
And yes, the biking scene is next to impossible with a touchscreen.
Right-click is more important than this drag&drop, since the latter is only used by a couple of games. So I can't just change the search button :P
Closing this now, this FT issue is resolved. I'll see what I can do about the various missing mapping...

comment:12 by SF/deejaydiabolik, 5 years ago

I have opened a new ticket for same problems on touche on android devices:
https://sourceforge.net/p/scummvm/bugs/6753/

Note: See TracTickets for help on using tickets.