Opened 8 years ago

Closed 8 years ago

#5748 closed defect (fixed)

WinCE: TeenAgent: Crashes and locks device

Reported by: SF/andrea2054 Owned by: CeRiAl
Priority: normal Component: Engine: TeenAgent
Keywords: Cc:
Game: TeenAgent

Description

Every time I try to start TeenAgent on my PocketPC device, ScummVM crashes and locks the device. I only obtain the black screen with the toolbar, but the device is inoperative and I must reboot it.
The same datafiles on the Windows version works well.
The issue happens on ScummVM 1.3.0 PocketPC port, running on HP iPAQ h2200 with Windows CE 4.20 italian

Ticket imported from: #3313813. Ticket imported from: bugs/5748.

Attachments (1)

scummvm_stdout.txt (4.8 KB ) - added by SF/andrea2054 8 years ago.
Log

Download all attachments as: .zip

Change History (21)

comment:1 by SF/megath, 8 years ago

Does it freeze before opening logos and animations? Did you try load game from launcher? (You could take pc savefile I guess)

comment:2 by SF/andrea2054, 8 years ago

The game freezes immediately, before opening logos and animations.
It freezes also loading games from launcher.

comment:3 by SF/megath, 8 years ago

Is it possible to get the logs from your device? It'd be better to set up log level higher to 2, for example.

by SF/andrea2054, 8 years ago

Attachment: scummvm_stdout.txt added

Log

comment:4 by SF/andrea2054, 8 years ago

I waited 10 minutes before rebooting the device, just to be sure.
I attached the requested logs.
scummvm_stderr.txt is empty.
Thanks for help.

comment:5 by SF/megath, 8 years ago

Could you add logs in TeenAgentEngine::run please?
Just after "inventory = new Inventory..." until "int load_slot = ...". First of all, We need to know that Inventory finished its constructor.
Thank you!

comment:6 by SF/andrea2054, 8 years ago

Could you explain how to do it?
Do you mean that I have to modify the Teen Agent Engine and then recompile it? Sorry, but I don't think that I have the competence to do it, or to set up a compile environment for PocketPC.
Maybe we can use the debugflags instead of the debuglevel?
Thank you

comment:7 by SF/megath, 8 years ago

Maybe we need to contact maintainer of the port to add logging and try to figure out what happened.

comment:8 by CeRiAl, 8 years ago

Owner: set to CeRiAl

comment:9 by SF/megath, 8 years ago

Have you tried any other game?

comment:10 by SF/andrea2054, 8 years ago

I generally use the 1.1.1 version because it doesn't have the bug #3313709.
With 1.3.0 I have successfully started (but not played) Inherit the Earth, Fascination, Freddy Pharkas, Nippon Safes and maybe some other game.

I can accept that there is some game that doesn't work on my PPC because of memory issues (Curse of Monkey Island, Woodruff, Drascula), but at least I got an error message, not a complete freeze of my device (it also stops the clock!)

comment:11 by lordhoto, 8 years ago

Summary: PocketPC port: TeenAgent crashes and locks deviceWinCE: TeenAgent: Crashes and locks device

comment:12 by SF/andrea2054, 8 years ago

The bug is still present in version 1.3.1

comment:13 by digitall, 8 years ago

andrea2054: Not good.. Could you check the following please? :
1. Try v1.3.1, ensuring that the included teenagent.dat is copied to the same folder as the game datafiles.
(Some games including Teenagent require a supplementary datafile, but the error handling if this is missing or an earlier
version can vary by engine.. If this fixes your issue, we will look at improving this for Teenagent)
2. Try the latest v1.4.0 development build from:
http://buildbot.scummvm.org/builds.html
If this fails, also check that the teenagent.dat included is not newer and fixes the issue if you replace the one in the
datafiles directory.
If this fixes your issue, we will look at backporting the fix from v1.4.0 to any possible v1.3.2+, though the conclusion
will probably be to use a v1.4.0pre build for now.

comment:14 by CeRiAl, 8 years ago

tdhs: I just made a few tests, and sadly I have to confirm that the bug is still present 1.3.1.
Strangely, this problem is gone in the current 1.4.0pre unstable version (as the Hugo 1 crash is). I suppose that there was a problem with the engine itself as I myself didn't fix anything in the unstable branch related to this bug. I will try to find out what exactly causes this problem.

comment:15 by digitall, 8 years ago

cerial23: Looking at the commits to engines/teenagent since v1.3.0 branch, this may be fixed by this commit on master:
5aa1877beffa71a2cc712a85b74a788e22a924e2 TEENAGENT: Allocate large buffers on the heap instead of the stack

If you cherry pick this locally to your branch-1-3 or locally revert this commit in your master working copy, you can build and confirm that this is the cause/fix of this issue.

If so, I'd suggest backporting by cherry-pick of this commit to branch-1-3 if we do release a v1.3.2 and advising the user to use v1.4.0pre development builds for Teenagent in the meantime.

comment:16 by SF/andrea2054, 8 years ago

Thanks! I've tried the version 1.4.0git1074-g5a1d0ab and the game starts normally! I've seen all the intro, and then the game seems to work!

comment:17 by SF/andrea2054, 8 years ago

Resolution: fixed

comment:18 by CeRiAl, 8 years ago

tdhs: It was indeed the commit:
5aa1877beffa71a2cc712a85b74a788e22a924e2 TEENAGENT: Allocate large
buffers on the heap instead of the stack
which fixed the problem. I've applied it to branch-1-3 and tested the resulting binary and the problem isn't existent any more (at least for me)

andrea2054: Could you please confirm if the bug is gone in the newest nightly-stable build also now? Thanks!

comment:19 by SF/andrea2054, 8 years ago

I confirm that TeenAgent now works on both versions 1.3.0pre153-gdfe0c78 and 1.4.0git1151-gcede1a3.

Thanks!

comment:20 by CeRiAl, 8 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.