Opened 9 years ago

Closed 9 years ago

#5707 closed defect (fixed)

SCI: Freddy Pharkas - Stuck in the brothel door

Reported by: SF/patryn Owned by: waltervn
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Freddy Pharkas: Frontier Pharmacist

Description

You can get stuck in the brothel door. I have added a save game, but this is how to replicate it on your own:

In act II, at night after putting out the flames go to Madam Ovaree's brothel, but do NOT pick up the postcards. Madam eventually appears and the act ends. In act III return there to pick up the postcards. When you exit from the brothel Freddy gets stuck in the door. This bug renders the game impossible to complete if the player takes this path.

Tested on the latest nightly build (19-05-2011), happens on both Windows and Android. The game is the English Talkie version.

Ticket imported from: #3304901. Ticket imported from: bugs/5707.

Attachments (2)

freddypharkas-cd.015 (56.2 KB ) - added by SF/patryn 9 years ago.
freddypharkas-cd.017 (53.6 KB ) - added by SF/patryn 9 years ago.

Download all attachments as: .zip

Change History (12)

by SF/patryn, 9 years ago

Attachment: freddypharkas-cd.015 added

comment:1 by SF/patryn, 9 years ago

Summary: Freddy Pharkas - Stuck in the brothel doorSCI: Freddy Pharkas - Stuck in the brothel door

comment:2 by digitall, 9 years ago

Replicated from the savegame with the latest Git master.
Looks like a pathfinding issue.

comment:3 by waltervn, 9 years ago

Owner: set to waltervn

comment:4 by waltervn, 9 years ago

I can confirm that this is indeed a pathfinding issue. I'm working it.

comment:5 by SF/patryn, 9 years ago

Some more information that might help: The pathfinding database gets dynamically updated at this point in the game.The brothel is generally not accessible during the day. This is the only occasion that Freddy can enter it during daytime, to pick up the postcards. After coming out the brothel goes back to becoming inaccessible (with the standard message of "This place only operates at night time" or similar).

comment:6 by waltervn, 9 years ago

Patryn, do you happen to have a nighttime savegame so I can compare?

by SF/patryn, 9 years ago

Attachment: freddypharkas-cd.017 added

comment:7 by SF/patryn, 9 years ago

Night-time save game attached (017).

comment:8 by waltervn, 9 years ago

Thanks patryn. With the nighttime savegame, I also get stuck at the door when I leave.

I know where the problem lies and I'll try to come up with a solution after checking in dosbox what the original interpreter does in this case.

comment:9 by waltervn, 9 years ago

Resolution: fixed
Status: newclosed

comment:10 by waltervn, 9 years ago

Fixed in 05ac17f.

Note: See TracTickets for help on using tickets.