Opened 8 years ago

Closed 6 years ago

#5679 closed defect (fixed)

SCI: QFG3: Note timing in intro

Reported by: wjp Owned by: wjp
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Quest for Glory 3

Description

This is in the scene in the QfG3 intro (as a wizard, in case it matters), when attacking Ad Avis.

After an initial segment, the foreground of the music consists of groups of three notes. In scummvm two of those three notes start to partially overlap after a short while. (dum-dum-dum dum-dum-dum dum-dum-dum dum-dum-dum becomes dum-dum-dum dum-ddum dum-dum-dum dum-ddum)
Tested with fmopl and a real MT-32.

In dosbox the notes stay separate.

Ticket imported from: #3293354. Ticket imported from: bugs/5679.

Change History (6)

comment:1 Changed 8 years ago by bluegr

Priority: normallow

comment:2 Changed 8 years ago by bluegr

Priority: lownormal

comment:3 Changed 8 years ago by wjp

Summary: QFG3: Note timing in introSCI: QFG3: Note timing in intro

comment:4 Changed 6 years ago by wjp

This is caused by midi loop commands being processed immediately, ignoring their delta.

comment:5 Changed 6 years ago by wjp

Owner: set to wjp
Resolution: fixed
Status: newclosed

comment:6 Changed 6 years ago by wjp

Fixed by f280789afe.

Note: See TracTickets for help on using tickets.