Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5649 closed defect (fixed)

Hero Quest 1 demo crashes

Reported by: (none) Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: script Cc:
Game: Quest for Glory 1

Description

The demo crashes when it start's the fight scene with the black (don't remember the name of the animal) the game aborts

Unknow kDisplay argument (0000:0075) from method battle::init(script11, local Call ffffffff)!

Ticket imported from: #3289744. Ticket imported from: bugs/5649.

Change History (7)

comment:1 by bluegr, 8 years ago

To process your bug report appropriately, please be so kind and provide the following information, if you have not done so yet:

* ScummVM version (PLEASE test the latest SVN/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 by bluegr, 8 years ago

Owner: set to bluegr

comment:3 by bluegr, 8 years ago

I assume that you're talking about the VGA demo version here. I can't reproduce the issue you're having. Please provide the information stated in the previous message

comment:4 by (none), 8 years ago

Sorry for being unclear:

ScummvM version 1.3.0git apr 22 2011 16:31:424

It's the version of the demo game downloaded here
http://demos.robertmegone.com/sci/qfg1-dos-ni-demo-en.zip
(Hero quest 1 EGA))

Platform Win7

I downloaded a fresh copy of the demo and the crash still happens. (you just have to let the demo run and it will crash when the batlle with the monster starts)

This is all the info I can give you. I hope it's enough

comment:5 by SF/mthreepwood, 8 years ago

Confirmed. I tested this demo last year for the SCI testing, and I didn't get it then. So, I'm guessing this is a regression sometime between r51742 and now.

-Matt

comment:6 by bluegr, 8 years ago

It's an unused subop (same as two more). Fixed in rev #6d05012

comment:7 by bluegr, 8 years ago

Keywords: script added
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.