Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5648 closed defect (fixed)

SCI: QFG2 can't buy healing pills

Reported by: SF/vcappe Owned by: wjp
Priority: high Component: Engine: SCI
Keywords: Cc:
Game: Quest for Glory 2

Description

ScummVM 1.3.0git4449-g12707e2 (Apr 16 2011 21:43:56)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib FluidSynth Theora

typing "buy healing pills" in the apothecary only results in "I have many pills for sell. Which do you want?" instead of the transaction actually taking place. bisection shows this bug to have been introduced in commit f98536eef5b24bf98730c3b555aeb63ed9de0927 (svn-id: r52989) back in october.

The bug also occurs with haggle/bargain instead of buy. Buying the other types of pills (vigor, cure poison, mana) works fine, tough.

To reproduce: load the attached save and type "buy healing pills". (note: the save was made with 1.2.1 to avoid version problems when bisecting).

Ticket imported from: #3288328. Ticket imported from: bugs/5648.

Attachments (1)

qfg2.002 (27.4 KB ) - added by SF/vcappe 9 years ago.
Save in the apothecary

Download all attachments as: .zip

Change History (9)

by SF/vcappe, 9 years ago

Attachment: qfg2.002 added

Save in the apothecary

comment:1 by wjp, 9 years ago

I can reproduce this. Workaround: "buy health pills"

The parser finds two meanings for 'healing': Type[0100] Group[0a88] / Type[0940] Group[04a4], and for 'buy healing pills' selects the 4a4 one. The said specs only look for a88.

As pointed out by the submitter, this is likely fixed by disabling multi-lingual support, since then the parser wouldn't even consider the 4a4 meaning.

comment:2 by sev-, 9 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:3 by sev-, 9 years ago

Priority: normalhigh

comment:4 by wjp, 9 years ago

...however, Sierra's QfG2 interpreter did contain the multi-lingual parser. It might be a difference in the order in which we try different expansions.

comment:5 by wjp, 9 years ago

Committed a major hack to the release branch to make this work temporarily (e7a006f)

comment:6 by fingolfin, 9 years ago

Summary: SCI:QFG2 can't buy healing pillsSCI: QFG2 can't buy healing pills

comment:7 by wjp, 9 years ago

SSCI only classifies the word 'healing' as group a88, and experimentation indicates it doesn't try suffix expansion after an exact match has been found. Fix committed to master (0788493015).

comment:8 by wjp, 9 years ago

Owner: set to wjp
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.