Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5584 closed defect

TOON: Speech stops working

Reported by: tsoliman Owned by: sylvaintv
Priority: normal Component: Engine: Toon
Keywords: Cc:
Game: Toonstruck

Description

Speech stops working in multiple places (e.g. after playing in wackman in the arcade) restoring a previous save doesn't fix it. Saving after the bug occurs and then quitting and loading the game again works.
Using trunk@55623
I am trying to get a save just before it happens but it seems to be random.

Ticket imported from: #3167932. Ticket imported from: bugs/5584.

Attachments (1)

toon.036 (24.5 KB ) - added by tsoliman 9 years ago.
Bad save

Download all attachments as: .zip

Change History (12)

comment:1 by digitall, 9 years ago

Owner: set to sylvaintv

comment:2 by digitall, 9 years ago

To process your bug report appropriately, please be so kind and provide the
following information, if you have not done so yet:

* ScummVM version (PLEASE test the latest SVN/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:3 by tsoliman, 9 years ago

This issue is gone in trunk@55668 now replaced by segfaults. I save often in an attempt to provide a savegame but every time it happens, I load the game and it doesn't happen in the same place. I play for a while more (saving every 3 mins or so) and when it segfaults, I load the last game and do the same thing that caused the segfault and it doesn't happen. I don't know what to do to provide a reproducible scenario.
Language: English
Platform: Linux compiled myself from svn (configure --enable-toon)

trunk@55623 didn't have the segfault but trunk@55668 did.

comment:4 by digitall, 9 years ago

I'm afraid that replicating this issue seems to be quite hard.
Since you are building your own binary, please can you confirm your Linux distribution, GCC and binutils versions.

Also could you try rebuilding from the latest trunk HEAD with "./configure --enable-toon && make clean && make" to see if the problem persists, but please try from a clean new game as it may be a corrupt savestate issue, so please attach a savegame which you have had the issue with.

The output of "./scummvm --version" on the result which should list compiled library options would also be useful.

comment:5 by tsoliman, 9 years ago

Distro: Debian sid
gcc 4:4.4.5-2
binutils 2.20.1-16

I will try to make clean but I usually delete all ignored files (which is like doing a fresh checkout)

I will also try to start over. These saves are probably messed up because they've been through a lot of revs (55623-55716) I didn't know we had to start a new game every time we svn update and rebuild but it makes sense.

by tsoliman, 9 years ago

Attachment: toon.036 added

Bad save

comment:6 by tsoliman, 9 years ago

Status: newclosed

comment:7 by tsoliman, 9 years ago

Starting a new game made the problem go away. Of course I was skipping all the dialog/videos this time but whatever.
I think we can close this now.
Thanks for the help.

comment:8 by raziel-, 9 years ago

ScummVM 1.3.0svn55789 (Feb 5 2011 18:07:07)
Features compiled in: Vorbis FLAC MP3 RGB zLib Theora

I didn't want to open another "No speech" item, so i add myself to this one, if i may?

I have the same problem, though not resolved.
I have copied the three dirs and the game is found, started and played, but there is NO speech whatsoever WITHIN the game...cutscenes like the intro work.
No explanation for objects (like the lock on the wardrobe) is spoken or given (seems the text output doesn't work either, but i haven't checked further on this one as i can't reach the option dialog with "F1"), nothing, if i want to talk to the foot in the very first screen there is silence and it simply skips back to the cursor icon (mouth) if tried

There is no warning or error on the console, not even with -d5, very strange

Toonstruck (Dos/English)

AmigaOS4 - PPC - SDL - BE
gcc (GCC) 4.2.4 (adtools build 20090118)

comment:9 by sylvaintv, 9 years ago

Do you hear any music? Or sound effect ?

comment:10 by tsoliman, 9 years ago

This is probably a silly suggestion but there's keyboard shortcuts for turning off speech and subtitles and it is possible to turn both off and be screwed. Can you try to use them. They are listed under help in the main menu.

comment:11 by raziel-, 9 years ago

@sylvaintv
@tsoliman

Music = yes (i can turn it on and off with "m")
Background music plays fine and can be turned on and off

Sound=yes (i can turn it on and off with "s")
i.e. the wiping sound of the cleaning foot can clearly be turned on and off

Text=NO
There is no on-screen text whatsoever.
Pressing "t" doesn't change a thing, no matter how often

Dialogue=NO
There is also no speech whatsoever.
Pressing "d" doesn't change a thing, see above.

As the Options Screen doesn't work ("F1") due to it being hard-coded i assume (same as with original Save/Load?) i can't check the settings, but i have no text/speech on starting a new game and pressing both "t" and "d" doesn't cure it, so it seems there is something wrong :-(
(I can't check with a saved game because i don't have one)

Note: See TracTickets for help on using tickets.