Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#5579 closed defect (invalid)

KYRA: Crash on startup on OS X due to invalid PAK file

Reported by: SF/tricky75 Owned by: lordhoto
Priority: high Component: Engine: Kyra
Keywords: Cc:
Game: Kyrandia 1

Description

ScummVM does recognize Kyrandia on my drive as a valid game, but whenever I try to run it ScummVM just crashes out without any notification why

Ticket imported from: #3166235. Ticket imported from: bugs/5579.

Change History (14)

comment:1 by lordhoto, 9 years ago

Owner: set to lordhoto
Status: newpending
Summary: Kyrandia won't run (MacOS X)KYRA: Crash on startup on OS X.

comment:2 by lordhoto, 9 years ago

To process your bug report appropriately, please be so kind and provide the following information, if you have not done so yet:

* ScummVM version (PLEASE test the latest SVN/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:3 by lordhoto, 9 years ago

You might also want to check your terminal output for any error messages, check here on how to do it: http://scummvm.sourceforge.net/faq/#5_6

comment:4 by SF/tricky75, 9 years ago

Status: pendingnew

comment:5 by SF/tricky75, 9 years ago

Ok, here are the answers you asked for:

* KYRANDIA version = 1.3
* ScummVM version = 1.2.1 (for MacOS X)
* Game Language = English
* Save Game = N/A
* On recently = I have only just started with ScumVM, so this is the first version I ever installed.

* Reproduction:
It's just like this, I point ScummVM to the directory where Kyrandia is installed on my system. SVM recognizes it as Kyrandia. Then I select start game and then ScummVM just ends itself without any message or anything. The ScummVM applications just terminates itself.

When it comes to error messages by using your terminal trick, I get the next error:
Couldn't load PAK file 'SAV_1.PAK'!

Well, that file does indeed not exist in my installation as the .PAK files the version I have installed are WSA1.PAK, WSA2.PAK, WSA3.PAK, WSA4.PAK, WSA5.PAK and WSA6.PAK. I don't know if renaming those files would do the trick...

comment:6 by lordhoto, 9 years ago

The problem isn't really that the file does not exist, but probably that you have a "SAV_1.PAK" file which isn't really a Kyra PAK file in some dir ScummVM searches, the extra path or theme path or your CWD comes to mind here. Currently ScummVM picks up all .PAK and .APK files and if one can not be loaded, because it contains invalid data / does not match the file format ScummVM will error out.

A temporary solution would be to look for that file and move it away.

comment:7 by SF/tricky75, 9 years ago

Hey, I found the file and indeed, I gave it a name I was sure of ScummVM wouldn't see it as part of the game and now it runs the game.

comment:8 by fingolfin, 9 years ago

It would still be very much preferable if ScummVM did proper error handling here, and showed an error dialog, instead of silently quitting (forcing the user to look at console output / a log file).

comment:9 by sev-, 8 years ago

This is back to the topic of duplicating the error messages in GUI

comment:10 by sev-, 8 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:11 by sev-, 8 years ago

Priority: normalhigh

comment:12 by fingolfin, 8 years ago

Summary: KYRA: Crash on startup on OS X.KYRA: Crash on startup on OS X due to invalid PAK file

comment:13 by lordhoto, 8 years ago

I added a simple possibility to output that error to the user via the debugger window in cfac223cee7cc8136fdf43dea1465a1b060a803b. That should take care of this for now.

comment:14 by lordhoto, 8 years ago

Component: Engine: Kyra
Game: Kyrandia 1
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.