Opened 9 years ago

Closed 9 years ago

#5566 closed defect (fixed)

QFG2: Script Error On last screen.

Reported by: SF/kithera Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: script Cc:
Game: Quest for Glory 2

Description

ScummVM 1.2.053544
Game: Quest for Glory 2 (DOS.English) (installed from anthology CD )
Installed on 32 bit Ubuntu via package

When entering the room where Ad Avis is attempting to summon Ibis, the interepter drops to the debug console, with an error about an uninitialized variable. Considering this is part of the original script, the default behavior should be to ignore, or warn and continue on such issues. Screenshot and savegame attached.

Ticket imported from: #3148418. Ticket imported from: bugs/5566.

Attachments (3)

Screeny.png (38.8 KB ) - added by SF/kithera 9 years ago.
Screenshot of error
qfg2-errLog (51 bytes ) - added by SF/kithera 9 years ago.
Error log
qfg2.013 (27.6 KB ) - added by SF/kithera 9 years ago.
Save Game just before error

Download all attachments as: .zip

Change History (7)

by SF/kithera, 9 years ago

Attachment: Screeny.png added

Screenshot of error

by SF/kithera, 9 years ago

Attachment: qfg2-errLog added

Error log

by SF/kithera, 9 years ago

Attachment: qfg2.013 added

Save Game just before error

comment:1 by wjp, 9 years ago

The error in the screenshot is truncated, but this is the full one:

Uninitialized read for temp 0 from method lightNextCandleS::changeState (script 500, room 500, localCall ffffffff)!

(To reproduce: type "cast open" and select the doors at the top of the stairs and walk through them)

The errLog file seems to be created by qfg2 itself, and doesn't seem relevant. (It contains the line 'RM704: r -> r: "Unknown word"')

comment:2 by wjp, 9 years ago

Regarding your comment on behaviour: that is in fact what should happen with release builds, but apparently the binary you're using doesn't seem to be built in release mode.

comment:3 by bluegr, 9 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:4 by bluegr, 9 years ago

Added a workaround for this in r55075

The value of this temp seems to be related to the frame used for each candle, but it is never initialized

Note: See TracTickets for help on using tickets.