Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5565 closed defect (fixed)

DIG: Subtitles won't turn off (regression)

Reported by: SF/jerrywoolsey Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

Between the 1.2.0 and 1.2.1 I can no longer turn off the subtitles in The Dig. I have attatched the two save files from both of the Windows7 64 bit versions of ScummVM.

Ticket imported from: #3145951. Ticket imported from: bugs/5565.

Attachments (2)

dig.s01 (26.9 KB ) - added by SF/jerrywoolsey 9 years ago.
1.2.1 version
dig.s00 (23.6 KB ) - added by SF/jerrywoolsey 9 years ago.
1.2.0 version

Download all attachments as: .zip

Change History (9)

by SF/jerrywoolsey, 9 years ago

Attachment: dig.s01 added

1.2.1 version

by SF/jerrywoolsey, 9 years ago

Attachment: dig.s00 added

1.2.0 version

comment:1 by digitall, 9 years ago

Located regression to :
r54665 | Kirben | 2010-11-30 07:57:42 +0000 (Tue, 30 Nov 2010) | 1 line

Fix bug #3093750 - FT: Truck and Aircraft computer text missing (regression).

which was backported to v1.2.0 branch in r54666.

However, just simplistically reverting this commit will correct this bug, but cause a reoccurence of bug #3093750 in Full Throttle :
https://sourceforge.net/tracker/?func=detail&aid=3093750&group_id=37116&atid=418820

Hopefully a fix can be created which corrects both issues.

comment:2 by Kirben, 9 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed
Summary: Text won't turn offDIG: Subtitles won't turn off (regression)

comment:3 by Kirben, 9 years ago

The problem was the speech detection code, which was never triggered before my changes, and was written for older SCUMM games (which didn't use iMuse Digital).

Fixed in ScummVM SVN, use the next daily snapshot of ScummVM SVN.

comment:4 by digitall, 9 years ago

Tested fixed trunk version :
ScummVM 1.3.0svn55051 (Dec 28 2010 04:23:38)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib FluidSynth Theora
on Linux x86_32

The fix is not sufficient. The FT Cockpit Computer seems OK i.e. the System is Damaged... text is shown and and the Dig subtitles don't appear _most_ of the time now. However, if you say ask Robbins a question at the beginning over the shuttle, the subtitle line still flickers up for about 0.5s at the end of the dialogue speech line. :/

comment:5 by digitall, 9 years ago

Resolution: fixed
Status: closednew

comment:6 by Kirben, 9 years ago

The original versions checked whether speech was been played at a different location in code, and the result was stored in _haveActorSpeechMsg.

Fixed in ScummVM SVN, use the next daily snapshot of ScummVM SVN.

comment:7 by Kirben, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.