Opened 8 years ago

Closed 3 years ago

Last modified 7 months ago

#5536 closed defect (fixed)

AMIGAOS4: White screen with OpenGL

Reported by: raziel- Owned by: lordhoto
Priority: normal Component: Port: AmigaOS4
Keywords: Cc:
Game:

Description

ScummVM 1.3.0svn54567 (Nov 29 2010 08:16:34)
Features compiled in: Vorbis FLAC MP3 RGB zLib Theora

Choosing any of the OpenGL display options giving me either a white screen or a white filled window.
I know this specific problem was fixed by Alejandro but i can't for my life remember the revision or what he did in the GSOC branch to fix it

AmigaOS4 - PPC - SDL - BE
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: #3122076. Ticket imported from: bugs/5536.

Attachments (2)

AmigaOS4-OpenGL.png (35.2 KB) - added by raziel- 8 years ago.
Wrong colors
AmigaOS4-OpenGL.diff (565 bytes) - added by raziel- 8 years ago.
This changes makes the white screen disappear but with wrong UI colors

Download all attachments as: .zip

Change History (16)

comment:1 Changed 8 years ago by raziel-

Forgot to add

Cursor is drawn (very big as if the resolution is at 324x240 or similar).
No OSD when switching between fullscreen/window

comment:2 Changed 8 years ago by raziel-

Summary: AMIGAOS: White screen with OpenGLAMIGAOS4: White screen with OpenGL

comment:3 Changed 8 years ago by raziel-

If i applie the following changes (taken from the last trunk, provided by vgvgf) i can make the white screen go away and show the launcher albeit in wrong colors

Changed 8 years ago by raziel-

Attachment: AmigaOS4-OpenGL.png added

Wrong colors

comment:4 Changed 8 years ago by digitall

raziel_ : A number of fixes have been applied recently for OpenGL Graphics. Please can you confirm if this problem still exists with the latest build from git master?

comment:5 Changed 8 years ago by raziel-

The issue still exists in 65b9e17 from today

sorry

comment:6 Changed 8 years ago by digitall

Owner: set to lordhoto

comment:7 Changed 8 years ago by digitall

No need for sorrow. Assigned to LordHoto who has kindly agreed to look at it with his Mac Mini i.e. also BE platform.

comment:8 Changed 8 years ago by lordhoto

I can not reproduce this on my Mac mini PPC, I guess your graphics driver / OpenGL implementation does not support the overlay color format as texture color format.

Since the overlay uses the same format as the OSD (and not the same as the cursor one), it pretty much hints at such a problem. Since other modes use the same color format as the overlay I am not sure whether this is easily fixable, except by converting all the data to RGBA8888 via software.

comment:9 Changed 8 years ago by lordhoto

Owner: lordhoto deleted

comment:10 Changed 8 years ago by raziel-

Overlay and the whole MiniGL implementation is rather limited on my platform

To get an idea of what is working take a look here:
http://os4depot.net/index.php?function=showfile&file=driver/graphics/minigl.lha
The source of MiniGL

Changed 8 years ago by raziel-

Attachment: AmigaOS4-OpenGL.diff added

This changes makes the white screen disappear but with wrong UI colors

comment:11 Changed 8 years ago by raziel-

It's getting a little better, speed in 640x480 is nearly back to normal in UI (see below, wrong colors though)
Games are pretty much unplayable due to massive slowdown

I uploaded a new .diff file (sorry, no git) which makes the white screen disappear.
I can use the menu, start and play games but to the drawback of having a wrong colored UI.

This i use
_overlayFormat = Graphics::PixelFormat(2, 4, 4, 4, 4, 12, 8, 4, 0);
instead of
_overlayFormat = Graphics::PixelFormat(2, 5, 5, 5, 1, 11, 6, 1, 0);

Can someone please explain to me what these numbers describe?
So i can test out different settings to find (maybe) one that works for me?

On testing right now i always get a "OpenGLGraphicsManager: Pixel format not supported!"

Thanks a lot

comment:12 Changed 3 years ago by raziel-

This specific behaviour has been fixed in the meantime.

Sorry, completely forgot about this bug.

comment:13 Changed 3 years ago by lordhoto

Owner: set to lordhoto
Resolution: fixed
Status: newclosed

comment:14 Changed 7 months ago by digitall

Component: Port: AmigaOS4
Note: See TracTickets for help on using tickets.