Opened 9 years ago

Closed 8 years ago

#5522 closed defect (wontfix)

AGI FAN Bob the Farmboy: Endless loop in outhouse

Reported by: raziel- Owned by: bluegr
Priority: normal Component: Engine: AGI
Keywords: script Cc:
Game: AGI Fanmade

Description

ScummVM 1.3.0svn54392 (Nov 20 2010 09:08:50)
Features compiled in: Vorbis FLAC MP3 RGB zLib Theora

Going to the outhouse and doing one of the things the "look" command suggests, leads to an endless loop with the interpreter telling "You're not close enough"

Bob The Farmboy (DOS/English)

AmigaOS4 - PPC - SDL - BE
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: #3113731. Ticket imported from: bugs/5522.

Attachments (1)

agi-fanmade-3.001 (2.0 KB) - added by raziel- 9 years ago.
"look" for further instructions :-)

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by raziel-

Attachment: agi-fanmade-3.001 added

"look" for further instructions :-)

comment:1 Changed 8 years ago by digitall

Replicated on Linux x86_32 with:
ScummVM 1.3.0git3509-g87d7044-dirty (Mar 1 2011 10:54:23)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib FluidSynth Theora

Replicated from attached savegame and clean start.

comment:2 Changed 8 years ago by sev-

Could you reproduce it with NAGI?

comment:3 Changed 8 years ago by raziel-

Nagi v2.06

Reproduceable

comment:4 Changed 8 years ago by bluegr

Owner: set to bluegr
Resolution: wontfix
Status: newclosed

comment:5 Changed 8 years ago by bluegr

This is a script bug with script 9: when you perform the action that the look command suggests, variable 210 is set to 2, but the check for it is incorrect and it is evaluates to true on every iteration of the script, thus the message "You're not close enough" keeps popping up over and over. There's not much that can be done about this one, it's a design flaw of the game, and since this is a fanmade game, the game's author should fix that. Closing as "won't fix".

Note: See TracTickets for help on using tickets.