Opened 9 years ago

Closed 8 years ago

#5521 closed defect (wontfix)

AGI FAN Bob the Farmboy: Erroneous cumulation of score

Reported by: raziel- Owned by: bluegr
Priority: normal Component: Engine: AGI
Keywords: script Cc:
Game: AGI Fanmade

Description

ScummVM 1.3.0svn54392 (Nov 20 2010 09:08:50)
Features compiled in: Vorbis FLAC MP3 RGB zLib Theora

Walk to the haystack and "take knife", repeat as often as you may, you will get score added to your overall as long as you do.
The same works with the hammer and nails in the barn (bot not with the toilet paper, the bucket and the water)

Bob The Farmboy (DOS/English)

AmigaOS4 - PPC - SDL - BE
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: #3113730. Ticket imported from: bugs/5521.

Attachments (2)

scummvm00000.png (6.2 KB ) - added by digitall 9 years ago.
Show errorneous score above maximum…
agi-fanmade.001 (3.4 KB ) - added by digitall 9 years ago.
Savegame For Replication

Download all attachments as: .zip

Change History (7)

comment:1 by digitall, 9 years ago

Replicated on Linux x86_32 with :
ScummVM 1.3.0git3509-g87d7044-dirty (Mar 1 2011 10:54:23)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib FluidSynth Theora

Attaching better screenshot and savegame to aid replication.
To replicate, just load the attached savegame and do "take knife".

by digitall, 9 years ago

Attachment: scummvm00000.png added

Show errorneous score above maximum...

by digitall, 9 years ago

Attachment: agi-fanmade.001 added

Savegame For Replication

comment:2 by sev-, 9 years ago

Could you reproduce it with NAGI?

comment:3 by raziel-, 9 years ago

Nagi v2.06

Reproduceable

comment:4 by bluegr, 8 years ago

Owner: set to bluegr
Resolution: wontfix
Status: newclosed

comment:5 by bluegr, 8 years ago

This is a script bug with scripts 3 (for the knife) and 5 (for the nails and hammer), as there is no check made whether the player already has the items or not. There's not much that can be done about this one, it's a design flaw of the game, and since this is a fanmade game, the game's author should fix that. Closing as "won't fix".

Note: See TracTickets for help on using tickets.