Opened 17 years ago

Closed 16 years ago

Last modified 10 years ago

#550 closed defect (fixed)

DIG: Bomp regressions

Reported by: eriktorbjorn Owned by: eriktorbjorn
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

So far I've noticed three regressions (along with some
improvements, of course) since aquadran's recent
bomp/codec5 rewrite:

1) Bomps no longer honor the topmost mask. Perhaps most
noticeably, the inventory window in The Dig will
obscure text. I've also seen some similar glitches in
Full Throttle and Sam & Max. (In all fairness, the Sam
& Max glitch was present in the original as well.)

2) Scaling is wrong, at least for the Sam & Max
"highway surfing" minigame. The roadsigns all appear
too big.

3) In The Dig, in the room that overlooks the landing
site and surrounding areas (crashed alien ship, animal
burial ground, etc.), if you bring up the inventory
window its colours are changing all the time.

1 is simple to fix. I'll submit a patch once I've
cleaned it up a bit. 2 is trickier since I don't
understand scaling tables and I only know how Sam & Max
uses it; not Dig and FT. I have no idea whatsoever
what's going on with 3. It doesn't look like there
should be any palette manipulations going on in this
room, and I don't think anything is deliberately
touching the shadow palette.

Ticket imported from: #635369. Ticket imported from: bugs/550.

Change History (8)

comment:1 Changed 17 years ago by SF/ender

One and Two should be fixed now.

comment:2 Changed 17 years ago by fingolfin

Component: --Unset--Engine: SCUMM
Game: The Dig
Summary: Bomp regressionsDIG: Bomp regressions

comment:3 Changed 17 years ago by SF/proff_fs

ScummVM 0.2.81 CVS
Built on Nov 14 2002 18:55:22 (GMT)
The Dig (German)
Win32 MP3 enabled

I can confirm bug #3

comment:4 Changed 17 years ago by SF/ender

Priority: normallow

comment:5 Changed 17 years ago by SF/ender

Three isn't a particually important bug, if it's just some odd colour
cycling. Lowering priority. (Considering as a 0.3.1 or 0.3.2 item)

comment:6 Changed 16 years ago by eriktorbjorn

The third issue now has its own bug report, #706721, so
let's close this old and cluttered one as (mostly) fixed.

comment:7 Changed 16 years ago by eriktorbjorn

Resolution: fixed
Status: newclosed

comment:8 Changed 10 years ago by Kirben

Owner: set to eriktorbjorn
Note: See TracTickets for help on using tickets.