Opened 17 years ago

Closed 17 years ago

Last modified 17 years ago

#551 closed defect (fixed)

LOOM: fade in / fade out

Reported by: SF/andrej4000 Owned by: fingolfin
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

ScummVM makes fade ins and fade outs, when
another room is loaded, but the original interpreter
didn't do that anywhere.
However the gameplay is a little bit strange with the
fade ins/outs.

Ticket imported from: #635461. Ticket imported from: bugs/551.

Change History (18)

comment:1 by SF/andrej4000, 17 years ago

Priority: normallow

comment:2 by eriktorbjorn, 17 years ago

When that feature was originally requested, I was told that
the original interpreter did do it, but that on modern
hardware it happens too fast to notice. I can't verify
whether that's true or false.

Anyway, as far as I can understand all screen effects (fades
and such) are scripted so ScummVM should do *something* when
changing rooms. It's just a question of whether or not we're
doing the correct screen effect. (And that's definitely open
to debate, since unkScreenEffect6() works differently in
Loom than in other games.)

comment:3 by SF/andrej4000, 17 years ago

Hm... it seems to me, that it wasm't really a fade in/out,
but just a much too slow computer.
E.g. in the beginning of the game the nightscreen is loaded
then a fade and again the nightscreen, but now with
animations. Here it is the fade absolutely senseless.

Also in the gameplay this feature "breaks" the flow of the
text, since some room changes are in the middle of dialogs,
and the fades are just ugly, because also the
synchronisation of voice and text is lost a little bit...

Perhaps on very old computers you just see how the
screen is schanged? (no real fade)

comment:4 by fingolfin, 17 years ago

I believe this might be fixed by a change I made today (to
fix Zak). Can you please check if that is the case? I don't
notice any fades during the intro... if the problem is still
there, could you please pin point to me where exactly I can
reproduce it?

comment:5 by fingolfin, 17 years ago

Owner: set to fingolfin
Status: newpending

comment:6 by SF/andrej4000, 17 years ago

It fixes at least the reload of the same room. (intro of
LoomVGA)
however there were no fades at all in the game.

comment:7 by SF/andrej4000, 17 years ago

Status: pendingnew

comment:8 by fingolfin, 17 years ago

You mean there are absolutly no, nada, rien, kein, zero
fades in Loom? Are you absolutly sure? It's been 10 years
for me I played the original, so I don't know myself.
But if this is true, it's not hard to fix, we could just
disable the fades for LoomCD.

comment:9 by SF/andrej4000, 17 years ago

I've never seen an fades and eriktorbjorn, too...

comment:10 by fingolfin, 17 years ago

Weird. I wonder why then there are calls to
o5_oldRoomEffect() in the script, setting the fade effect to 2.
A possible explanation would be that o5_oldRoomEffect() has
a different meaning in Loom.

comment:11 by SF/andrej4000, 17 years ago

Perhaps no meaning at all? They converted all scripts from
the old game. Perhaps after that thy just removed the
fades?

comment:12 by eriktorbjorn, 17 years ago

In feature request #596788 [1] ("More fade modes")
logicdeluxe claimed there definitely were fade-ins and
fade-outs in Loom CD. Is there any way we could arrange a
duel to the death between him and andrej4000 to find out
which one of them is right about this? :-)

Or could it be something simpler, e.g. that
_switchRoomEffect / _switchRoomEffect2 should be cleared
once they've been used? As I've said, I've never seen what
Loom CD looks like on a really slow computer, and I've never
been able to run it under DOSemu or DosBox.

http://sourceforge.net/tracker/index.php?func=detail&aid=596788&group_id=37116&atid=418823

comment:13 by SF/andrej4000, 17 years ago

OK... With a very good slowdown program in slowest mode
on my P2-350 I saw very fast fades... (peh... now you can
speel good eriktorbjorn, your work _HAS_ sense... :p ) I
don't knwo for which computers it was designed for, but I
don't think the fades should be as slow, as scummvm uses
them.

perhaps just making the fades a little bit faster?

comment:14 by eriktorbjorn, 17 years ago

Speeding up the fade would be very simple: Just change the
blits_before_refresh variable in dissolveEffect() to
something larger.

Though I think it looks pretty good for the other games
(it's used sparingly in Indy4, MI1, Sam & Max, and possibly
others) so maybe just change it a bit for Loom since that
game uses it so extensively?

comment:15 by SF/andrej4000, 17 years ago

sounds good! as Cpt. Picard would say: "make it so!" ;)

comment:16 by fingolfin, 17 years ago

OK, I can do it.

Interesting side note: unkScreenEffect6() already has a
conditionalized call to dissolveEffect, for LoomCD it uses
different parameters...

comment:17 by fingolfin, 17 years ago

I sped the fade up by a factor 4, looks OK here. We can
still fine tune it if you think it should be even faster or
a tad slower again.

comment:18 by fingolfin, 17 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.