Opened 9 years ago

Closed 9 years ago

#5379 closed defect (fixed)

GOB3: Confused pathfinder

Reported by: SF/warepire Owned by: DrMcCoy
Priority: low Component: Engine: Gob
Keywords: Cc:
Game: Goblins 3

Description

When telling Blount to go to an area that is stair-like he can sometimes after reaching the approximate area start walking back and forth between 2 close points. Give him a new destination to end this behavior.

How to re-create it: After Blount comes out of the cabin, set his destination to the point marked by the arrow in the screen shot. (Do not click the actual square but the black area right above it), the bug also occurred for me in Death but there I cannot reproduce it for this bug report.

ScummVM build: 1.2.0 REV 52800 win32
Game version: Goblins 3, CD/DOS/v1.02 (English)

Ticket imported from: #3072165. Ticket imported from: bugs/5379.

Attachments (1)

screenshot.PNG (22.3 KB ) - added by SF/warepire 9 years ago.

Download all attachments as: .zip

Change History (7)

by SF/warepire, 9 years ago

Attachment: screenshot.PNG added

comment:1 by SF/warepire, 9 years ago

Summary: Confused pathfinderGoblins 3: Confused pathfinder

comment:2 by sev-, 9 years ago

Owner: set to DrMcCoy
Summary: Goblins 3: Confused pathfinderGOB3: Confused pathfinder

comment:3 by DrMcCoy, 9 years ago

Yes, that's a known glitch in the pathfinding code.

comment:4 by DrMcCoy, 9 years ago

Priority: normallow

comment:5 by DrMcCoy, 9 years ago

Should be fixed in the SVN repo. Please try a recent checkout or the next daily build.

comment:6 by DrMcCoy, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.