Opened 9 years ago

Closed 8 years ago

#5325 closed defect (fixed)

WINCE: broken sword 2 game crash

Reported by: SF/szcbawokon Owned by: CeRiAl
Priority: high Component: Engine: Sword2
Keywords: Cc:
Game: Broken Sword 2

Description

Game crashes when i'm trying to show toolbar , after more then two done things ( talk, use item etc.)n . In stderr file ( or some like that i don't remember name) is writing that is out of memory error, but when i start i have over 60 MB of RAM Free.
DEVICE: Toshiba G900
Language : Englisg
Version of game: CD Windows
Platform : WINCE
Tried scummvm versions: 1.1.1, 1.0( on which i played on broken sword 1), on newest nightly build game is not loading ( it gives flac error).Tried both one(over 10 MB) and two( less than 10 MB each, of course version for sword1 engine) binaries.

Ticket imported from: #3058262. Ticket imported from: bugs/5325.

Change History (10)

comment:1 by fingolfin, 9 years ago

Summary: [WINCE] broken sword 2 game crashWINCE: broken sword 2 game crash

comment:2 by sev-, 9 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:3 by sev-, 9 years ago

Priority: normalhigh

comment:4 by CeRiAl, 9 years ago

Owner: set to CeRiAl

comment:5 by CeRiAl, 9 years ago

I am able to reproduce this bug - well, the current git-build (one .exe file) crashes directly after the starting the game. Had 73 MB of free memory on a HTC Touch Pro.
However, I've built a version of ScummVM with only the sword2 engine included and this version seems to work nicely (played about 20mins). I have attached this special test build to this bug.
It seems that the WinCE port suffers from the same problem as the NDS version and others: not enough memory for an executable which contains all engines. The other ports have solved this problem (AFAIK) with plugins, that means only the "current" engine gets loaded into memory. The last official build of ScummVM for WinCE had two executables because of this.
So there's a short term solution (not so nice) and a long term solution for this problem:
* Create even more ScummVM executables for WinCE (three, four?)
* Create a plugin system for WinCE (knakos and others already seem to have started dll-based plugins for WinCE, I have to look into this to know how exactly it works/what has to be done to make it work correctly).

Please check if the attached version works for you, to rule out that there's another problem.

comment:6 by CeRiAl, 9 years ago

Ok, file was too big, here's a URL for downloading:
http://pocketinsanity.org/scummvm-sword2.zip

comment:7 by CeRiAl, 8 years ago

Shouldn't crash any more in 1.3.0, can you confirm this?

comment:8 by CeRiAl, 8 years ago

Chaning the status of this bug to pending, will close it after 14 days if there's no further complaint, as all tests seem to indicate that the problem doesn't exist anymore after the new engine .exe-splitting in 1.3.0 & 1.3.1.

comment:9 by CeRiAl, 8 years ago

Status: newpending

comment:10 by CeRiAl, 8 years ago

Resolution: fixed
Status: pendingclosed
Note: See TracTickets for help on using tickets.