Opened 9 years ago

Closed 9 years ago

#5191 closed defect (fixed)

SCI0/01 parser issues

Reported by: SF/ponytear999 Owned by:
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Leisure Suit Larry 3

Description

Game: Leisure Suit Larry 3 French
Game Version: DOS/French
ScummVM Version: 1.2.0svn51831
Operating System: Windows XP Media Center 32

Game not completable because the game keeps telling me I don't have the knife when I try to cut the grass (but I can carve the wood).
Just to make sure, I tried to play in DOSBox and I could get the grass without any problem. I also completed LSL3 English (1.003 Oct 27 1989) with the full score without any problem.

Ticket imported from: #3041215. Ticket imported from: bugs/5191.

Attachments (1)

lsl3-fr.000 (29.8 KB) - added by SF/ponytear999 9 years ago.

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by SF/ponytear999

Attachment: lsl3-fr.000 added

comment:1 Changed 9 years ago by SF/mthreepwood

Summary: Game says I don't have the knife when I try to cut the grassLSL3: Game says I'm missing the knife when cutting the grass

comment:2 Changed 9 years ago by digitall

Ponytear, since this sounds like an issue with the input parser, can you confirm the exact french phrase you
are using?

For the English version, I have used "CUT GRASS WITH KNIFE" for this action.

It would probably be useful to attach the output from using the debug console (CTRL+D during game) commands,
"parser_words" as a text file.

Also, you could also attach the message from the debug command "parse <command sentence>" where <command sentence> is the exact french phrase. The output should show how that is being parsed.

comment:3 Changed 9 years ago by SF/ponytear999

How can I create a textfile with the debug info? It seems I can't copy the text from ScummVM to the notepad and I can't find any option to dump it directly from ScummVM. I searched the forums and manual but couldn't find anything...

The French input for cutting the grass is SCIE HERBE.

Actually there seems to be more problems with the input parser than I first mentioned. The French version of LSL3 allows to play the game in full English, full French or a mix of the two (you can change the setup anytime during the game). Until now, I had always played the game with English input and English or French text since all walkthroughs were for the English input version.

Therefore I played the game with English input until the grass problem. Both English and French input are not allowing me to cut the grass.

But yesterday I played from the beginning with the French input and some problems appear earlier, ie: I can pick up the wood with the English input but cannot with the French input. I can open the mailbox with the English input but not with the French input.

One reason I cannot open the box with the French input is because ScummVM
doesn't handle the letters with accents very well (or not at all?), in this case the î ('i' with circumflex accent) from "boîte" (= box). Opening the box in French is OUVRE BOÎTE (with the circumflex on the 'i') but trying to type î appears incorrectly as ^i in the game (and the word BOITE without accent is not recognized by the game).

Listing the parser words in the debug window has the same problem: the accents are not displayed properly. The "parser_words" command sometimes displayed English words and sometimes French words as I was playing the full French version.

Let me know how I can dump the debug messages and I will attach the files.

comment:4 Changed 9 years ago by m-kiewitz

we already know that there is a bigger problem with the parser.

Sierra SCI had the ability to put a word into several word groups. We are currently not able to do so, only one group is possible per word. So if the game asks for a 2nd group, we wont find it.

Could you please use sci viewer and check, if the vocab resources really contain boîte? I don't have any french parser game, so i can't check.

comment:5 Changed 9 years ago by m-kiewitz

Summary: LSL3: Game says I'm missing the knife when cutting the grassSCI0/01 parser issues

comment:6 Changed 9 years ago by SF/ponytear999

I tried SCI Viewer, SCI Companion and SCI Studio and none of them can read the French vocab resources ("unsupported vocab resource"). They can only read the English vocab resources.
The only way I can confirm that boîte exists in the parser is because it works when playing the game in DOSBox.

comment:7 Changed 9 years ago by wjp

Resolution: fixed
Status: newclosed

comment:8 Changed 9 years ago by wjp

I have added some features for international versions this weekend, and that should have fixed your problem.
Note that the changes are only in the 1.3.0svn version, not in the 1.2.0pre one. If you run into any trouble with the 1.3.0svn version with LSL3-fr, please let us know.

Note: See TracTickets for help on using tickets.