Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5190 closed defect (fixed)

KQ5CD: Random crashes when loading and saving

Reported by: SF/escarlate Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: King's Quest 5

Description

I'm playing through KQ5CD, and experiencing random crashes when saving and restoring. This is the console log after one crash:

WARNING: kDoBresen: destination x, y would be off-screen(330, 179)!
WARNING: kDoBresen: destination x, y would be off-screen(330, 73)!
WARNING: kDoBresen: destination x, y would be off-screen(330, 179)!
WARNING: kDoBresen: destination x, y would be off-screen(330, 73)!
WARNING: kDoBresen: destination x, y would be off-screen(330, 179)!
WARNING: kDoBresen: destination x, y would be off-screen(330, 73)!
WARNING: kDoBresen: destination x, y would be off-screen(330, 73)!
WARNING: kDoBresen: destination x, y would be off-screen(330, 73)!
WARNING: kDoBresen: destination x, y would be off-screen(330, 179)!
WARNING: kDoBresen: destination x, y would be off-screen(330, 73)!
WARNING: kDoBresen: destination x, y would be off-screen(330, 73)!
WARNING: kDoBresen: destination x, y would be off-screen(330, 179)!
WARNING: kDoBresen: destination x, y would be off-screen(330, 73)!
WARNING: Attempt to peek invalid memory at 0000:0000!
WARNING: Attempt to peek invalid memory at 0000:0004!
WARNING: Attempt to peek invalid memory at 0000:0000!
WARNING: Attempt to peek invalid memory at 0000:0002!
WARNING: Attempt to peek invalid memory at 0000:0000!
WARNING: Attempt to peek invalid memory at 0000:0004!
WARNING: Attempt to peek invalid memory at 0000:0000!
WARNING: Attempt to peek invalid memory at 0000:0002!
WARNING: kDoBresen: destination x, y would be off-screen(330, 123)!
WARNING: kDoBresen: destination x, y would be off-screen(330, 73)!
WARNING: Attempt to peek invalid memory at 0000:0000!
WARNING: Attempt to peek invalid memory at 0000:0004!
WARNING: Attempt to peek invalid memory at 0000:0000!
WARNING: Attempt to peek invalid memory at 0000:0002!
WARNING: Attempt to peek invalid memory at 0000:0000!
WARNING: Attempt to peek invalid memory at 0000:0004!
WARNING: Attempt to peek invalid memory at 0000:0000!
WARNING: Attempt to peek invalid memory at 0000:0002!
WARNING: kDoBresen: destination x, y would be off-screen(80, 205)!
WARNING: kDoBresen: destination x, y would be off-screen(339, 129)!
WARNING: kDoBresen: destination x, y would be off-screen(339, 182)!
WARNING: kDoBresen: destination x, y would be off-screen(275, 225)!
WARNING: kStrAt offset FFFF exceeds maxSize!
WARNING: kStrAt offset FFFF exceeds maxSize!
WARNING: kDoBresen: destination x, y would be off-screen(339, 112)!
WARNING: kDoBresen: destination x, y would be off-screen(110, 249)!
WARNING: kDoBresen: destination x, y would be off-screen(330, 157)!
WARNING: kDoBresen: destination x, y would be off-screen(339, 127)!
WARNING: kDoBresen: destination x, y would be off-screen(339, 149)!
WARNING: kDoBresen: destination x, y would be off-screen(339, 138)!
WARNING: kDoBresen: destination x, y would be off-screen(88, 249)!
WARNING: kDoBresen: destination x, y would be off-screen(339, 132)!
WARNING: Attempt to peek invalid memory at 0000:0000!
WARNING: Attempt to peek invalid memory at 0000:0004!
WARNING: Attempt to peek invalid memory at 0000:0000!
WARNING: Attempt to peek invalid memory at 0000:0002!
WARNING: Attempt to peek invalid memory at 0000:0000!
WARNING: Attempt to peek invalid memory at 0000:0004!
WARNING: Attempt to peek invalid memory at 0000:0000!
WARNING: Attempt to peek invalid memory at 0000:0002!
WARNING: Attempt to peek invalid memory at 0000:0000!
WARNING: Attempt to peek invalid memory at 0000:0004!
WARNING: Attempt to peek invalid memory at 0000:0000!
WARNING: Attempt to peek invalid memory at 0000:0002!
WARNING: kDoBresen: destination x, y would be off-screen(339, 115)!
WARNING: kDoBresen: destination x, y would be off-screen(339, 142)!
WARNING: kDoBresen: destination x, y would be off-screen(339, 112)!
WARNING: Attempt to peek invalid memory at 0000:0000!
WARNING: Attempt to peek invalid memory at 0000:0004!
WARNING: Attempt to peek invalid memory at 0000:0000!
WARNING: Attempt to peek invalid memory at 0000:0002!

Game Version: CD/DOS/English/version 1.000.052
ScummVM Version: 1.2.0svn51831
Operating System: Win32 (XP SP2)

Ticket imported from: #3041195. Ticket imported from: bugs/5190.

Change History (7)

comment:1 by m-kiewitz, 9 years ago

the whole warning log has nothing to do with it. Please find out when it's crashing, so that i can reproduce it. Does it crash when both saving AND loading?

comment:2 by SF/escarlate, 9 years ago

Yes, when both loading and saving within the game. I click on the restore or save option in the restore or save screen, and ScummVM freezes. The crash is a complete lock-up, where ScummVM stops responding and has to be terminated with the task manager. The only other place that something similar happens is in the witch's castle, when Graham reaches it before killing her. I was using the MT-32 emulator while doing my playthrough, don't know if it has something to do with the problem. It's a bit hard to reproduce it, since it's so random. While I was playing, I tried to kill Graham as much as I could, to test all the death sequences, so I was saving and restoring a lot! :)

comment:3 by m-kiewitz, 9 years ago

that's strange. There is a known issue where ScummVM gets a deadlock when restoring. But i have never experienced this happening when saving.

Do you mean when actually saving/restoring or when going to the save/restore menu?

comment:4 by SF/escarlate, 9 years ago

Well, the lock-up happens after clicking on the restore or save button (either on the top menu, or in the options box that come after Graham dies). I don't remember if it produced corrupt saves... I don't think so.

comment:5 by SF/escarlate, 9 years ago

Now that the GUI is completely replaced by ScummVM, it doesn't happen anymore. I guess this can be closed then...

comment:6 by bluegr, 9 years ago

The lockup at the screen of the witch's house, before killing her is a separate issue.

Anyway, closing as requested

comment:7 by bluegr, 9 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.