Opened 9 years ago

Closed 9 years ago

#5168 closed defect (fixed)

QFG3: Music fails to stop/loop in certain areas

Reported by: SF/kuroshiro Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Quest for Glory 3

Description

Quest for Glory 3 (Dos/English)
ScummVM 1.2.0SVN 51782
Windows 7 x64

In the inn, music will not properly loop once it finishes, leading to silence at times. Conversely, the music when you leave the Simbani village does not stop and properly transition to the music for the Savannah until you go somewhere else. This isn't true of all areas, just those two.

Ticket imported from: #3040616. Ticket imported from: bugs/5168.

Change History (9)

comment:1 by SF/negativeiq, 9 years ago

At least in the case of the Simbani village / Savannah, this is not a bug. As the Savannah map screen (the one in which the Simbani village is) uses the same background music as the Simbani village itself, when leaving the Simbani village and entering the Savannah, the music simply continues (even in the original game). However when going vice versa the music should restart.

comment:2 by bluegr, 9 years ago

Can you please attach a savegame? Otherwise, it's very hard to reproduce this

comment:3 by bluegr, 9 years ago

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:4 by bluegr, 9 years ago

As a guess, this has probably happened because of a bug that existed with the music fading code, which has been fixed. Since the original submitter hasn't attached a savegame, I'm going to change this to "Pending", cause I believe that it has been fixed, but I have no way of reproducing it. Also, from what negativeiq says, this is normal behavior at least in one scene, so again I'm convinced that this isn't an actual bug in ScummVM anymore

comment:5 by bluegr, 9 years ago

Owner: set to bluegr
Resolution: worksforme
Status: newpending

comment:6 by SF/kuroshiro, 9 years ago

Hi, sorry I missed this before. You seem to be correct as I cannot reproduce this bug anymore. The music loops properly at the inn now.

comment:7 by SF/kuroshiro, 9 years ago

Status: pendingnew

comment:8 by bluegr, 9 years ago

Resolution: worksformefixed
Status: newclosed

comment:9 by bluegr, 9 years ago

Thanks for your feedback :) Glad it works indeed

Closing then

Note: See TracTickets for help on using tickets.