Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4960 closed defect (wontfix)

SQ4CD: Sequel Police shoot too quickly

Reported by: SF/kuroshiro Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: original Cc:
Game: Space Quest 4

Description

Game: Soace Quest 4 (CD/Dos/English)
ScummVM Version: 1.2.0SVN 51294
OS: Windows 7 x64

In the beginning (SQ12), after you take the ship into sequel police headquarters, you have to go right and jump into one of the time capsules before the sequel police notice you. However, they react and shoot you before you can do anything. They should delay for a couple of seconds, allowing you to use the hand icon on the capsule. This renders the game impossible to complete.

Ticket imported from: #3034656. Ticket imported from: bugs/4960.

Attachments (1)

sq4.000 (43.8 KB ) - added by SF/kuroshiro 9 years ago.
sq4 sequel police (head left)

Download all attachments as: .zip

Change History (8)

comment:1 by bluegr, 9 years ago

Try cranking up the game speed from the menu, Roger is too slow if the speed isn't high enough. This is a bug with the game scripts, which we work around, but the original behavior is to be fast enough in this scene anyway.

If you still have issues, please attach a savegame

by SF/kuroshiro, 9 years ago

Attachment: sq4.000 added

sq4 sequel police (head left)

comment:2 by SF/kuroshiro, 9 years ago

It's not exactly that Roger is too slow, it's that they fire INSTANTLY. However, you are correct, if the speed is up all the way then you can get to the module, and they will not fire right away. If the speed slider is even a pixel below the top, they will kill you instantly. I'll attach a save game anyway.

comment:3 by sev-, 9 years ago

Component: Engine: SCI
Game: Space Quest 4

comment:4 by bluegr, 9 years ago

Keywords: original added
Owner: set to bluegr
Resolution: wontfix
Status: newclosed

comment:5 by bluegr, 9 years ago

Closing as "also occurs in the original"

comment:6 by bluegr, 9 years ago

Update: This bug should be fixed with the script patches by NRS, here:
http://www.sierrahelp.com/Patches-Updates/Patches-Updates-Games/SpaceQuestSeriesUpdates.html

comment:7 by m-kiewitz, 9 years ago

Another update: i just tried it again and it seems the scene is now playing just fine. I guess it was fixed by my speed throttler change in kAnimate. The patches not needed.

Note: See TracTickets for help on using tickets.