Opened 9 years ago

Closed 9 years ago

#4794 closed defect (fixed)

Zak/FM-Towns: Game hangs when using monkey wrench

Reported by: SF/inguin Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Zak McKracken

Description

In Zak McKracken (FM-TOWNS/English), when I use the monkey wrench to remove the pipe of Zak's sink the mouse cursor disappears and the game stops running. ScummVM itself is still responsive, i.e. I can open the debug console or leave fullscreen mode.

100% reproducible in 1.1.0svn48155 (see attached savegame)
not reproducible in ScummVM 1.0.0 (Fedora 12 x86-32 package)

Ticket imported from: #2961530. Ticket imported from: bugs/4794.

Attachments (1)

zak-fm.s01 (17.8 KB) - added by SF/inguin 9 years ago.
Savegame immediately before freeze

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by SF/inguin

Attachment: zak-fm.s01 added

Savegame immediately before freeze

comment:1 Changed 9 years ago by Kirben

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:2 Changed 9 years ago by Kirben

This was a regression, caused by revision 47473. Since loopEnd only has a valid value, when sound looping is required.

Fixed in ScummVM SVN, use the next snapshot of ScummVM SVN.

Note: See TracTickets for help on using tickets.