Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4784 closed defect (fixed)

PUTTPUTT: No Load/Save possible

Reported by: raziel- Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Putt-Putt Joins the Parade

Description

ScummVM 1.1.0svn48143 (Feb 27 2010 07:06:24)
Features compiled in: Vorbis FLAC MP3 RGB zLib

Saving/Loading through the in-game menu is not possible because the menu does not come up with "S" and "L".
All other set keys (i.e. "Q" for ingame information) work.

The other 3DO game (PUTT-PUTT on the Moon) i have installed work as expected
I need to add that i haven't tried the in-game save menu due to ScummVMs menu working so well back then

PUTT-PUTT joins the Parade (English/3DO)

gcc version 4.2.4 (adtools build 20090118)

Ticket imported from: #2960022. Ticket imported from: bugs/4784.

Attachments (1)

HE PuttPutt1 - Load Screen.png (62.3 KB ) - added by raziel- 10 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 by Kirben, 10 years ago

Does the load/save screen actually exist in this 3DO version? it looks like it should be room 48, which you can use the debugger to access.

comment:2 by raziel-, 10 years ago

Yes, it does
Room 48 is the "Load Game" screen

What is funny is that the background is Kayla's home from "Fatty Bears birthday surprise

by raziel-, 10 years ago

comment:3 by Kirben, 10 years ago

Sounds like the 3DO version didn't offer a scripted load/save screen, judging by that image. I noticed load/save fails in the initial DOS version of puttputt too.

Fixed in ScummVM (branch and trunk), by still allowing loading and saving in these older HE games.

comment:4 by Kirben, 10 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed
Summary: PUTTPUTT 1: No Load/Save possiblePUTTPUTT: No Load/Save possible

comment:5 by raziel-, 10 years ago

Not to "rain on your parade" :-D (sorry) :-)
but i think you wanted to do it the other way round?

Now ALL of the HE games have the "Load" button unghosted EXCEPT Putt Putt 1 3DO
(Loading and Saving from th emnu is possible when inside the game, though)

I may be wrong, but i believe vice versa would be more logical? ;-)

comment:6 by Kirben, 10 years ago

Are you sure you are using fresh build of current ScummVM (branch or trunk)? as I can't reproduce that at all.

The 'Load' button is still disabled in launcher and GUI menu, in later HE games. While earliest HE games, can load and save via the GUI menu again.

comment:7 by raziel-, 10 years ago

Yes, just did a fresh build of branch 1.1.0 and all "Load" buttons are accessable except Putt Putt 1 and Pajama Sam 1

comment:8 by Kirben, 10 years ago

Are you referring to the ''Load' button in the launcher or in the GUI menu (via F5), or both?

The 'Load' button in launcher should be disabled for all HE games. But only for recently added games, unless force upgrade of config file (via --upgrade-targets option) or start fresh config file.

comment:9 by raziel-, 10 years ago

I am referring to the Load button in laucher, the ingame menu works as you mentioned it, launcher does not :-)

Just for the fun of it i added Pajama Sam 2 (one of the games, laucher Load is accessable) and whee it's still accessable ;-)

The upgrade tagets option didn't cure it either

comment:10 by Kirben, 10 years ago

Strange, when you use the upgrade targets option, did you see messages like this?
-> update guioptions to 'launchNoLoad'

And if you check the scummvm config file, do HE games have this option?
guioptions=launchNoLoad

comment:11 by raziel-, 10 years ago

Yes, i only have one line ready, becasue i didn't save it

Looking at target 'simon2', gameid 'simon2' ...
-> update guioptions to 'launchNoLoad'

comment:12 by Kirben, 10 years ago

Could you please check your ScummVM config file, as requested too.

The 'launchNoLoad' setting of guioptions, is what disables the 'Load' button in the launcher for each game target.

comment:13 by raziel-, 10 years ago

Truly sorry, missed that part

After the upgrade there was no guioption set to puttputt

I did a Mass Add after deleting scummvm.ini and i got this then
[puttputt-3do]
platform=3do
gameid=puttputt
description=Putt-Putt Joins the Parade (3DO/English)
language=en
path=Miscellaneous:Games/ScummVM/PuttPutt1
guioptions=launchNoLoad

comment:14 by raziel-, 10 years ago

OK, so i think this can be finally closed

I added every game i had and tried afterwards
It works now like you said

I am very sorry for all the mischief :-(

Note: See TracTickets for help on using tickets.