Opened 12 years ago

Closed 12 years ago

#4749 closed defect (fixed)

MANIAC - Italian NES version (extracted) not recognized

Reported by: SF/somescummvmfan Owned by: sev-
Priority: normal Component: Engine: SCUMM
Version: Keywords: detection
Cc: Game: Maniac Mansion

Description

Good day. I have noticed that the Italian version for Maniac Mansion (NES) is not being detected if it's extracted with the extract_mm_nes tool.

The following is the line that could be added to tools/scumm-md5.txt for this version: fa3cb1541f9d7cf99ccbae6249bc150c -1 it NES NES extracted -

Also, somewhat related to this, the md5sum that exists in that table for the Italian NES version (not the extracted one) is incorrect. It's the digest for the first 5000 bytes of "Maniac Mansion (I).prg", not for the whole file which is what the detector computes (since it's under 1MB). I guess it was left like that at some point in the past when scummvm only calculated digests for the first 5000 bytes for scumm games, but it should be corrected.

So, the following line:

e28bc6dbec750bced1b7c98d6caa32ce 262144 it NES NES - -

Should be replaced with this one: 54a68a5f5e3c86da42b7ca5f51e79b1d 262144 it NES NES - -

Thanks for everything!

Ticket imported from: #2930306. Ticket imported from: bugs/4749.

Change History (3)

comment:1 by SF/quietust, 12 years ago

I can confirm that the proposed checksum is correct, as it matches the ROM image from which I originally determined the resource offsets.

comment:2 by sev-, 12 years ago

Thanks, fixed.

comment:3 by sev-, 12 years ago

Owner: set to sev-
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.