Opened 10 years ago

Closed 10 years ago

#4681 closed defect (fixed)

COMI: crash / sound errors on Symbian S60v5

Reported by: SF/bluppfisk Owned by: anotherguest
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

Running Monkey Island 3 on a Symbian S60v5 device such as the Nokia 5800 XpressMusic will result in odd behaviour.

* There will be either no sound or some sound but only up to a certain point.
* The animations get stuck until you press the skip line button command (.)
* Changes (such as subtitle speed and subtitle/sound/both toggles) made in either the game menu or the ScummVM configuration have no effect on the actual game.
* The latter also seems to go for Day of the Tentacle

See forum thread:

http://forums.scummvm.org/viewtopic.php?t=7434&postdays=0&postorder=asc&start=0

Ticket imported from: #2883739. Ticket imported from: bugs/4681.

Change History (8)

comment:1 by SF/bluppfisk, 10 years ago

* Finally the game will get completely stuck with no option to skip lines or animations any more. The menu however remains accessible, so it's not a true crash.

comment:2 by fingolfin, 10 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest SVN/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:3 by fingolfin, 10 years ago

Owner: set to anotherguest
Summary: MI3 on Symbian S60v5 devices will crash / sound errorsCOMIN: crash / sound errors on Symbian S60v5

comment:4 by fingolfin, 10 years ago

Summary: COMIN: crash / sound errors on Symbian S60v5COMI: crash / sound errors on Symbian S60v5

comment:5 by SF/bluppfisk, 10 years ago

ScummVM v1.0.0rc1 (30 Aug 2009)
Launching the game is enough to swiftly see what is wrong. You may want to skip a few scenes in the beginning to get to the actual problem.
Language: English
Game version: Original CD
On SymbianS60v5 (touchscreen edition)
No savegame needed, the error occurs straight away.
Bug's been there since I started using ScummVM on my phone.

comment:6 by fingolfin, 10 years ago

Thanks!

comment:7 by anotherguest, 10 years ago

Problem was in the SDL symbian port. I made a mistake in the thread implementation, and not installing a cleanupstack like was done in the other SDL port. Well. well. Some how the DIGIMUSE was calling symbian code requiring a cleanupstack and puff bang.

comment:8 by anotherguest, 10 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.