Opened 10 years ago

Closed 10 years ago

#4676 closed defect (worksforme)

DW1: Some speech isn't played when speech file is compressed

Reported by: SF/ezekiel000 Owned by: m-kiewitz
Priority: normal Component: Engine: Tinsel
Keywords: Cc:
Game: Discworld

Description

Some of the speech isn't played so subtitles are used instead once I compress the english.smp file.
The first line not to be played is the first line of the wizard outside Rincewinds door in the intro.

ScummVM 1.0.0rc1 (Aug 22 2009 15:46:53) (Features compiled in: Vorbis FLAC MP3 ALSA zLib FluidSynth)
ScummVM Tools 1.0.0rc1
Ubuntu 9.04
Discworld 1 (English GRA version)

Ticket imported from: #2881430. Ticket imported from: bugs/4676.

Change History (11)

comment:1 by SF/ezekiel000, 10 years ago

Sorry I should have mentioned I'm running Ubuntu 9.04 amd64

comment:2 by lordhoto, 10 years ago

Owner: set to m-kiewitz

comment:3 by lordhoto, 10 years ago

Looks like m_kiewitz wrote the tool, at least according to DrMcCoy's commit message.

m_kiewitz: Do you have any ideas what causes this? Are you able to reproduce it?

comment:4 by m-kiewitz, 10 years ago

Can't reproduce here, although I'm using Windows (XP 32-bit) and I'm also using the compressed files that I compressed when the tool was done (MP3).

There may have been changes to that code. Isn't there also a GUI tool now?

Anyway an MD5 and size of your english.idx and english.smp would be helpful including the actual compression type you used.

comment:5 by m-kiewitz, 10 years ago

Just making sure that I'm checking the right thing - it seems you are talking about the "wants to speak with you" line that is played after the knocks on the door, right?

comment:6 by SF/ezekiel000, 10 years ago

I just tested it again with the latest svn build and this bug doesn't appear any more.
Well the first line of the Wizard outside the door after the knocking plays now, but I haven't done more extensive testing.
The compress smp is in ogg format, but I guess that doesn't matter now that it seems to be working.

comment:7 by m-kiewitz, 10 years ago

May have been a sound regression, the common sound code was changed a lot in the last few months.

Please test some more, if possible. Otherwise please tell us to close this issue.

comment:8 by SF/ezekiel000, 10 years ago

I'll try to find time latter to test some more and let you know.

comment:9 by lordhoto, 10 years ago

Since this bug was reported with 1.0.0rc1, which was without any sound system changes, I doubt that is related in the sense that it broke it. Of course maybe some sound related changes fixed this by chance too.

comment:10 by SF/ezekiel000, 10 years ago

I did a bit more testing and I didn't come across any missing audio and subtitles showing up instead. So I think this bug can be closed.

comment:11 by m-kiewitz, 10 years ago

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.