Opened 10 years ago

Closed 10 years ago

Last modified 12 months ago

#4622 closed defect (fixed)

SVN compile error on Mac OS X 10.6.1 in browser.h

Reported by: SF/dominus Owned by: vinterstum
Priority: normal Component: Port: Mac OS X
Keywords: build Cc:
Game:

Description

I tried to compile ScummVM on Mac OS X 10.6.1 and ran into the following compile error:
C++ gui/browser.o
gui/browser.cpp: In member function ‘virtual int GUI::BrowserDialog::runModal()’:
gui/browser.cpp:56: error: ‘NavDialogRef’ was not declared in this scope
gui/browser.cpp:56: error: expected `;' before ‘dialogRef’
gui/browser.cpp:58: error: ‘NavDialogCreationOptions’ was not declared in this scope
gui/browser.cpp:58: error: expected `;' before ‘options’
gui/browser.cpp:59: error: ‘NavUserAction’ was not declared in this scope
gui/browser.cpp:59: error: expected `;' before ‘result’
gui/browser.cpp:60: error: ‘NavReplyRecord’ was not declared in this scope
gui/browser.cpp:60: error: expected `;' before ‘reply’
gui/browser.cpp:75: error: ‘options’ was not declared in this scope
gui/browser.cpp:75: error: ‘NavGetDefaultDialogCreationOptions’ was not declared in this scope
gui/browser.cpp:82: error: ‘dialogRef’ was not declared in this scope
gui/browser.cpp:82: error: ‘NavCreateChooseFolderDialog’ was not declared in this scope
gui/browser.cpp:84: error: ‘dialogRef’ was not declared in this scope
gui/browser.cpp:84: error: ‘NavCreateChooseFileDialog’ was not declared in this scope
gui/browser.cpp:87: error: ‘dialogRef’ was not declared in this scope
gui/browser.cpp:87: error: ‘NavDialogGetWindow’ was not declared in this scope
gui/browser.cpp:89: error: ‘NavDialogRun’ was not declared in this scope
gui/browser.cpp:94: error: ‘result’ was not declared in this scope
gui/browser.cpp:94: error: ‘NavDialogGetUserAction’ was not declared in this scope
gui/browser.cpp:96: error: ‘kNavUserActionChoose’ was not declared in this scope
gui/browser.cpp:97: error: ‘reply’ was not declared in this scope
gui/browser.cpp:97: error: ‘NavDialogGetReply’ was not declared in this scope
gui/browser.cpp:117: error: ‘NavDisposeReply’ was not declared in this scope
gui/browser.cpp:121: error: ‘NavDialogDispose’ was not declared in this scope
make: *** [gui/browser.o] Error 1

This is caused by carbon no longer being availlable on OS X 10.6.1
By adding #undef MACOSX just before the line #ifdef MACOSX in gui/browser.h was I able to continue with the compilation.

Ticket imported from: #2868456. Ticket imported from: bugs/4622.

Change History (3)

comment:1 by fingolfin, 10 years ago

Vinterstum fixes this quite some time ago.

comment:2 by fingolfin, 10 years ago

Owner: set to vinterstum
Resolution: fixed
Status: newclosed

comment:3 by digitall, 12 months ago

Component: Port: Mac OS X
Note: See TracTickets for help on using tickets.