Opened 17 years ago

Closed 16 years ago

#458 closed defect (fixed)

ZAK256: airport door opens too early

Reported by: SF/martingu Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Zak McKracken

Description

When moving from the "gates exit" directly to the airport
exit door it opens already when Zak is in the middle of
the room and closes too early. You have to walk away a
little bit for the door to open again.

Ticket imported from: #607496. Ticket imported from: bugs/458.

Attachments (1)

zak256.s01 (32.1 KB) - added by SF/martingu 17 years ago.
Load Savegame and try to reproduce bug

Download all attachments as: .zip

Change History (12)

Changed 17 years ago by SF/martingu

Attachment: zak256.s01 added

Load Savegame and try to reproduce bug

comment:1 Changed 17 years ago by SF/martingu

I forgot to add:
Snapshot Sep 10 2002 00:03:12 used

comment:2 Changed 17 years ago by fingolfin

Is this with a completly new game, or using an older save game? I am
asking because this problem is supposed to be fixed, only older save
games ought to be affected; leaving and re-entering the room should fix
this.

comment:3 Changed 17 years ago by SF/martingu

The problem has gotten better with the Sep15 release, but
when you walk to the exit door straight out of the plane the
issue still exists. If you don't go to the exit door immediately
or if you enter the airport from the exit door, the problem is
fixed.
I noticed this using the latest Win32 Daily Snapshots.

comment:4 Changed 17 years ago by SF/martingu

Sorry, again forgot something. This happens with the
savegame attaced and Win32 build Sep11 and with the sep15
build and a completely new game.

comment:5 Changed 17 years ago by fingolfin

Owner: set to fingolfin

comment:6 Changed 17 years ago by fingolfin

OK what I found so far: there are three boxes in this room.
Box 0 is the normal "ground" box. Box 1 & 2 are on the left
/ right side of the room, and apparently *both* trigger the
door on the right. Which is kind of strange. If there was a
door on the left, I would expect box 1 to control that, alas
there isn't. A look at the scripts involved may reveal more.

comment:7 Changed 17 years ago by fingolfin

OK what I found so far: there are three boxes in this room.
Box 0 is the normal "ground" box. Box 1 & 2 are on the left
/ right side of the room, and apparently *both* trigger the
door on the right. Which is kind of strange. If there was a
door on the left, I would expect box 1 to control that, alas
there isn't. A look at the scripts involved may reveal more.

comment:8 Changed 17 years ago by SF/thanius

Well, I've got a build from 6th December and I can't even
get through those damned airport doors sometimes.

comment:9 Changed 17 years ago by fingolfin

Owner: fingolfin deleted

comment:10 Changed 16 years ago by fingolfin

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:11 Changed 16 years ago by fingolfin

Problem was an opcode which we implemented wrong since forever,
basically (roughly spoken: the doors look for the object/actor closest to
them; if that object is close enough, the door opens. Problem was, the
opcode which should find the ID of the closest actor/object returned the
*distance* instead of the object ID - that of course resulted in pretty random
behavior).

Note: See TracTickets for help on using tickets.