Opened 11 years ago

Closed 11 years ago

#4547 closed defect (fixed)

DW2: crash in cartwheel stage

Reported by: SF/domino1983 Owned by: dreammaster
Priority: normal Component: Engine: Tinsel
Keywords: original Cc:
Game: Discworld II

Description

When you click in the right down corner in the cartwheel scene, scummvm crashes with this error:

Assertion failed: InPolygon(*ptgtX, *ptgtY, PATH) != NOPOLY, file engines/tinsel /move.cpp, line 190

This application has requested the Runtime to terminate it in an unusual way. Please contact the application's support team for more information.

I've attached a savegame, just click in the right down corner.

Tested on scummvm 1.0.0pre043480, Win32, English version of the game

Ticket imported from: #2840397. Ticket imported from: bugs/4547.

Attachments (1)

dw2-gb.003 (2.3 KB ) - added by SF/domino1983 11 years ago.

Download all attachments as: .zip

Change History (5)

by SF/domino1983, 11 years ago

Attachment: dw2-gb.003 added

comment:1 by SF/domino1983, 11 years ago

Summary: crash im cartwheel stageDW2: crash in cartwheel stage

comment:2 by dreammaster, 11 years ago

Congratulations - you've discovered a bug in the original game.. I even went back to the original game executable to verify it.

The problem is that the polygonal area comprising the bottom right-hand corner of the screen in this scene has a 'walk to' point of 494,418. However, this isn't contained in any walkable 'PATH' polygonal area. Hence the assert. I'll have to experiment on how best to adjust the walk position of this polygon so it's in a walkable area.

comment:3 by dreammaster, 11 years ago

Keywords: original added
Owner: set to dreammaster

comment:4 by dreammaster, 11 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.