Opened 10 years ago

Closed 9 years ago

#4527 closed defect (wontfix)

DW: Animation Glitch?

Reported by: SF/tim20 Owned by: dreammaster
Priority: normal Component: Engine: Tinsel
Keywords: original Cc:
Game: Discworld

Description

I'm not sure if this is in the original source code, but something strange happens when you try to open the little Scared Guy's safe, in L-Space, as a ghost:

If you double click on the jewelry box, Rincewind's animation for opening the safe seems to act a little strangely. One second he opens the safe and removes the hammer, then he's not holding it and the safe is closed, then it's open and he's holding it again, then finally he's not holding it and it's shut again once he's finished speaking.

Also, in the bathroom, it says 'Soap' next to the plant pot when it's not even there.

Language: English
Version: Talkie/DOS
Platform: Win32/Windows XP - Home Edition with SP3
ScummVM: 1.0.0pre043166 (Aug 9 2009 20:29:33)

Ticket imported from: #2834437. Ticket imported from: bugs/4527.

Attachments (1)

dw.001 (3.4 KB ) - added by SF/tim20 10 years ago.

Download all attachments as: .zip

Change History (9)

by SF/tim20, 10 years ago

Attachment: dw.001 added

comment:1 by SF/tim20, 10 years ago

Summary: Animation Glitch?Discworld - Animation Glitch?

comment:2 by fingolfin, 10 years ago

Summary: Discworld - Animation Glitch?DW1: Animation Glitch?

comment:3 by dreammaster, 10 years ago

For the soap at least, I think the problem is that the highlight area is incorrect - given that it talks about 'soap on tap', I'm presuming that the hotspot should be centered on the small tap that's at the back of the bath.

comment:4 by fingolfin, 9 years ago

So this is a bug in the original game data?
Any chance of a workaround, Paul?

comment:5 by fingolfin, 9 years ago

Owner: set to dreammaster
Summary: DW1: Animation Glitch?DW: Animation Glitch?

comment:6 by fingolfin, 9 years ago

Paul?

comment:7 by dreammaster, 9 years ago

I think I'll have to leave this in the "can't easily fix" category. From what I can see of the script, it launches a play reel which contains the entire sequence, including both Rincewind and the picture area. The script then carries on, launching the talk messages in description.

The problem here is that the play sequence is actually shorter than the text length, and the play reel is finishing before the talking is, so it's returning to the standard character animation before starting a new one for the 'I'm sure I'll figure what to do' animation starts.

Unfortunately, there's no way for the play reel to know that it should pause at certain frames until any on-screen text and/or sample is finished. So without a lot of messy hardcoded logic to freeze that specific animation at specific frames, there's no clean way to fix this.

comment:8 by dreammaster, 9 years ago

Keywords: original added
Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.