Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4513 closed defect (wontfix)

ITE: High CPU usage

Reported by: SF/andru84 Owned by: bluegr
Priority: normal Component: Engine: SAGA
Keywords: Cc:
Game: Inherit the Earth

Description

ScummVM Version: 0.13 for OSX Leopard

Bug Details:
I've setup Inherit the Earth on my Macbook (standard issue 2Ghz intel C2D, 1gb ram), but am noticing extreme CPU usage issues. Currently I am unable to play the game without the fan going full tilt. I've tried many different game settings in order to attempt to minimize the cpu usage, but nothing seems to work. Under activity monitor (OSX equivalent of task manager), ScummVM consistently takes up about 80% of my CPU.
[see forum post here for further details: http://forums.scummvm.org/viewtopic.php?t=7731]

Note, I've never had this issue while running ScummVM on my PC (thought I may have just not noticed as it's not a laptop and high CPU usage is less noticeable).

Language: English
Version: Full speech CD version of ITE
Platform: Mac OSX Leopard
Savegame: N/A

Ticket imported from: #2831281. Ticket imported from: bugs/4513.

Change History (7)

comment:1 by SF/andru84, 10 years ago

Summary: High CPU usage on mac osxHigh CPU usage on mac osx (ITE)

comment:2 by criezy, 10 years ago

Just to reap what I wrote in the forum post mentioned by the initial submitter:
I can see the same problem with my iMac and it seems to be graphic related as the CPU usage depends a lot on the graphics mode used (and more specifically on the scaling).
HQ3X: 81%
3X: 72%
2X: 50%
normal (no scaling): 25%

With all the other games I tried with HQ3X the CPU usage is less than 40%

comment:3 by lordhoto, 10 years ago

Summary: High CPU usage on mac osx (ITE)ITE: High CPU usage on mac osx

comment:4 by lordhoto, 10 years ago

Summary: ITE: High CPU usage on mac osxITE: High CPU usage

comment:5 by lordhoto, 10 years ago

I have the same 'problem' on my Linux/PPC machine. It's having a CPU usage around 55% for ScummVM and having around 20% CPU usage on Xorg, resulting in ~75% CPU usage.

I guess this is because the game does no proper dirty rect handling, or only very basic. As criezy pointed out the CPU usage is really much depending on the graphics scaler, so this is probably also evidence for the dirty rect handling.

I suspect that this also applies to IHNM, thus being generic in the SAGA engine, but I don't have IHNM to test.

comment:6 by sev-, 10 years ago

Yes, the problem is that the engine updates whole screen. And there is not too much we can do because of the background animation in majority of the screen. md5 started some experimental work, but did not finish it.

Won't fix in the time being.

comment:7 by sev-, 10 years ago

Owner: set to bluegr
Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.