Opened 10 years ago

Closed 10 years ago

#4491 closed defect (invalid)

WOODRUFF: GFX Glitches

Reported by: SF/kuroshiro Owned by: DrMcCoy
Priority: low Component: Engine: Gob
Keywords: Cc:
Game: Woodruff

Description

I tested The Bizzare Adventures of Woodruff and the Schnibble(Dos/English) on Windows XP using the July 26th 1.0.0 SVN build.

I encountered 3 noticable graphical glitches while playing, though no major reproducable bugs.

1). This is by far the most noticable/critical. During the introduction sequence, everything looks fine at first, but when the box appears in the forground over the background of the hill, the foreground area is fine, but the bg colors go completely nuts (See: http://img259.imageshack.us/img259/292/woodruffintro.png).

2). When you try to use the Bluxtre Nut on the X to break it with the meteor but have *not* covered it with tar, the animation that plays of it rolling away seems to be bugged, not erasing frames properly. (See: http://img259.imageshack.us/img259/4526/woodruffnut.png)

3). This is the least noticable but still bugged me. When you're talking with Azimuth in his cell, whenever he turns away at the end of a dialogue, woodruff will be surrounded by a slightly discolored rectangle. (See: http://img529.imageshack.us/img529/8980/woodruffbox.png)

Ticket imported from: #2828858. Ticket imported from: bugs/4491.

Attachments (1)

woodruff-gb.s09 (17.4 KB ) - added by SF/kuroshiro 10 years ago.
Savegame at Azimuth's Cell

Download all attachments as: .zip

Change History (6)

comment:1 by DrMcCoy, 10 years ago

1) Is already fixed in the SVN repository. This was a regression produced by me trying to fix a different GFX glitch ( https://sourceforge.net/tracker/?func=detail&aid=2037158&group_id=37116&atid=418820 )

2) Could you give me savegame at that position? From the looks of it, I think it's the same bug as 1) though

3) I'd like a savegame for that too. Though it looks like a slight palette disagreement between the talking video and the normal game palette, This is a bug in the original data files, but I could try to add a workaround for it.

comment:2 by DrMcCoy, 10 years ago

Owner: set to DrMcCoy
Priority: normallow

by SF/kuroshiro, 10 years ago

Attachment: woodruff-gb.s09 added

Savegame at Azimuth's Cell

comment:3 by SF/kuroshiro, 10 years ago

Restested on the latest SVN -- 1 & 2 are indeed both fixed, 3 is not. Attached a save in Azimuth's cell. Just talk to him to see the glitch at the end of the dialogue..

comment:4 by DrMcCoy, 10 years ago

Resolution: invalid
Status: newclosed

comment:5 by DrMcCoy, 10 years ago

Okay, looked into that and it's not a palette mismatch. It's an actual error in the video, the frame data really redraws that rectangle in those different colors.

Moving this to the wiki.

Note: See TracTickets for help on using tickets.